summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2012-04-17 14:47:43 +0200
committerDenys Dmytriyenko <denys@ti.com>2012-04-18 12:19:55 -0400
commit62e713b1b309e9e38e2de288da8470f10c61fbc3 (patch)
tree97f81eedca3768119f7f209af63331bf43fb45fa /recipes-bsp
parentf026aa7bd09a75034b28a0aa7e750059fd2c2813 (diff)
downloadmeta-ti-62e713b1b309e9e38e2de288da8470f10c61fbc3.tar.gz
am33x-cm3: add firmware for am33x suspend/resume
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ti/am33x-cm3_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/ti/am33x-cm3_git.bb b/recipes-bsp/ti/am33x-cm3_git.bb
new file mode 100644
index 00000000..247ba4d8
--- /dev/null
+++ b/recipes-bsp/ti/am33x-cm3_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Cortex-M3 binary blob for suspend-resume"
2
3LICENSE = "TI-BSD"
4LIC_FILES_CHKSUM = "file://License.txt;md5=858099c817e47ea63559fc6b67ae8d91"
5
6PV = "04.06.00.07"
7SRCREV = "cf07b841d6e8c5e026eecb259d143f3dff412c8e"
8
9SRC_URI = "git://arago-project.org/git/projects/am33x-cm3.git"
10
11S = "${WORKDIR}/git"
12
13do_compile() {
14 make CC="${TARGET_CC}" CROSS_COMPILE="${TARGET_PREFIX}"
15}
16
17do_install() {
18 install -d ${D}${base_libdir}/firmware
19 install -m 0644 bin/am335x-pm-firmware.bin ${D}${base_libdir}/firmware/
20}
21
22FILES_${PN} = "${base_libdir}/firmware"
23