diff options
author | Franklin S. Cooper Jr <fcooper@ti.com> | 2012-09-01 12:45:03 -0500 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2012-10-10 16:00:04 -0400 |
commit | 2a3c7305fb81967d1358e731fb564182480b0338 (patch) | |
tree | e24e172ef679c89e782a6ed3cce84c3ef7acfb61 /recipes-bsp | |
parent | 80ebdb06c319c5fa9881923e4a158eb048487b66 (diff) | |
download | meta-ti-2a3c7305fb81967d1358e731fb564182480b0338.tar.gz |
recipes: Fix ti-eula-unpack issue. Tweak sgx modules and libgles recipes.
* Commit d8fc4a686262c50fd0053afa7240020909ec430b addressed an issue where
too many newlines characters were being sent since print by default already
sends a newline character. This commit however resulted in bin files being
installed in the WORKDIR and broke other recipes which commit
a94f765b9867abefd5f0bd262b5dddb8782b3187 addressed. This lead to a very
cluttered WORKDIR.
* This patch updates ti-eula-unpack.inc to switch from using a print to a write.
Since write doesn't automatically send newlines it is a bit more obvious when
newlines are sent.
* Part of the reason that bin files were being installed in the WORKDIR was
due to TI_BIN_UNPK_WDEXT being blank for some recipes. For instance in the
libgles-omap3 recipes, when the workdir command is set in TI_BIN_UNPK_CMDS the
directory that the Graphics SDK will be installed into is
workdir+TI_BIN_UNPK_WDEXT. A blank TI_BIN_UNPK_WDEXT means the SDK will be
installed in WORKDIR. By setting TI_BIN_UNPK_WDEXT to a proper value the
recipes can be sure it is installed in the proper directory.
* Determine which file to download based on the defined BINFILE and not a
hardcoded value. This idea was taken from arago.
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com>
Acked-by: Chase Maupin <chase.maupin@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb b/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb index 0affee1e..4f9be7bc 100644 --- a/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb +++ b/recipes-bsp/powervr-drivers/omap3-sgx-modules_1.6.16.3977.bb | |||
@@ -11,17 +11,17 @@ BINFILE := "Graphics_SDK_setuplinux_${SGXPV}.bin" | |||
11 | 11 | ||
12 | inherit module | 12 | inherit module |
13 | 13 | ||
14 | MACHINE_KERNEL_PR_append = "a" | 14 | MACHINE_KERNEL_PR_append = "b" |
15 | PR = "${MACHINE_KERNEL_PR}" | 15 | PR = "${MACHINE_KERNEL_PR}" |
16 | 16 | ||
17 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/Graphics_SDK_setuplinux_${SGXPV}.bin \ | 17 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/gfxsdk/${SGXPV}/exports/${BINFILE} \ |
18 | file://Compile-fixes-for-38-kernel.patch \ | 18 | file://Compile-fixes-for-38-kernel.patch \ |
19 | file://kernel-30.patch \ | 19 | file://kernel-30.patch \ |
20 | " | 20 | " |
21 | SRC_URI[md5sum] = "ff8c1f2b8e4cb42f4ced6a613b081ada" | 21 | SRC_URI[md5sum] = "ff8c1f2b8e4cb42f4ced6a613b081ada" |
22 | SRC_URI[sha256sum] = "cdb0bd3964e107733d632aa8224e0537b05c1ffac34befc036423458c8d75255" | 22 | SRC_URI[sha256sum] = "cdb0bd3964e107733d632aa8224e0537b05c1ffac34befc036423458c8d75255" |
23 | 23 | TI_BIN_UNPK_WDEXT="/Graphics_SDK_${SGXPV}" | |
24 | S = "${WORKDIR}/Graphics_SDK_${SGXPV}/GFX_Linux_KM" | 24 | S = "${WORKDIR}${TI_BIN_UNPK_WDEXT}/GFX_Linux_KM" |
25 | 25 | ||
26 | PVRBUILD = "release" | 26 | PVRBUILD = "release" |
27 | export KERNELDIR = "${STAGING_KERNEL_DIR}" | 27 | export KERNELDIR = "${STAGING_KERNEL_DIR}" |