summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-10-16 09:58:44 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-16 09:58:44 +0200
commiteed6b351b299408a71aaa4115608b311271535f4 (patch)
treea2021ca4f02d6612146828f987875aadd0ef4043 /recipes-bsp
parent99ce37e4a9c1cbfe534528584c67577d07c825ae (diff)
downloadmeta-ti-eed6b351b299408a71aaa4115608b311271535f4.tar.gz
u-boot: switch beagleboard and beaglebone to RO rootfs at boot
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09/0003-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.09.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb3
4 files changed, 56 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09/0003-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch b/recipes-bsp/u-boot/u-boot/2011.09/0003-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch
new file mode 100644
index 00000000..3c6743e9
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09/0003-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch
@@ -0,0 +1,26 @@
1From 78080b20d8daa8e80f962beeab898d171bcc8eac Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 16 Oct 2011 09:37:38 +0200
4Subject: [PATCH 3/3] beagleboard: mount rootfs RO instead of RW at boot
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/omap3_beagle.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
12index a67e5a0..95a134b 100644
13--- a/include/configs/omap3_beagle.h
14+++ b/include/configs/omap3_beagle.h
15@@ -231,7 +231,7 @@
16 "dvimode=640x480MR-16@60\0" \
17 "defaultdisplay=dvi\0" \
18 "mmcdev=0\0" \
19- "mmcroot=/dev/mmcblk0p2 rw\0" \
20+ "mmcroot=/dev/mmcblk0p2 ro\0" \
21 "mmcrootfstype=ext3 rootwait\0" \
22 "nandroot=/dev/mtdblock4 rw\0" \
23 "nandrootfstype=jffs2\0" \
24--
251.6.6.1
26
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch
new file mode 100644
index 00000000..28877463
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch
@@ -0,0 +1,26 @@
1From 9f8585887a08e6a9c7ca24c2a9c0e9a8c66a2a54 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 16 Oct 2011 09:57:06 +0200
4Subject: [PATCH 3/3] am335x-evm: make rootfs RO on boot
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/am335x_evm.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h
12index cb45037..5db3d9f 100755
13--- a/include/configs/am335x_evm.h
14+++ b/include/configs/am335x_evm.h
15@@ -50,7 +50,7 @@
16 "script_addr=0x81900000\0" \
17 "console=ttyO0,115200n8\0" \
18 "mmc_dev=0\0" \
19- "mmc_root=/dev/mmcblk0p2 rw\0" \
20+ "mmc_root=/dev/mmcblk0p2 ro\0" \
21 "nand_root=/dev/mtdblock4 rw\0" \
22 "spi_root=/dev/mtdblock4 rw\0" \
23 "nor_root=/dev/mtdblock3 rw\0" \
24--
251.6.6.1
26
diff --git a/recipes-bsp/u-boot/u-boot_2011.09.bb b/recipes-bsp/u-boot/u-boot_2011.09.bb
index 223ccb90..8eef7c71 100644
--- a/recipes-bsp/u-boot/u-boot_2011.09.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.09.bb
@@ -1,6 +1,6 @@
1require u-boot.inc 1require u-boot.inc
2 2
3PR = "r3" 3PR = "r4"
4 4
5# No patches for other machines yet 5# No patches for other machines yet
6COMPATIBLE_MACHINE = "(beagleboard)" 6COMPATIBLE_MACHINE = "(beagleboard)"
@@ -12,6 +12,7 @@ SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
12 file://2011.09/0001-beagleboard-add-support-for-TCT-Beacon-board.patch \ 12 file://2011.09/0001-beagleboard-add-support-for-TCT-Beacon-board.patch \
13 file://2011.09/0001-beagleboard-add-support-for-scanning-loop-through-ex.patch \ 13 file://2011.09/0001-beagleboard-add-support-for-scanning-loop-through-ex.patch \
14 file://2011.09/0002-beagleboard-switch-to-ttyO2.patch \ 14 file://2011.09/0002-beagleboard-switch-to-ttyO2.patch \
15 file://2011.09/0003-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch \
15 file://fw_env.config \ 16 file://fw_env.config \
16 " 17 "
17 18
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index a5338308..314446a4 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "beaglebone" 4COMPATIBLE_MACHINE = "beaglebone"
5DEFAULT_PREFERENCE_beaglebone = "99" 5DEFAULT_PREFERENCE_beaglebone = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r6" 7PR = "r7"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"
@@ -14,6 +14,7 @@ UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
14SRC_URI = "git://github.com/trini/u-boot.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \ 14SRC_URI = "git://github.com/trini/u-boot.git;protocol=git;branch=int_am335xpsp_04.06.00.01-v2011.09-for-sdk-05.03.00.00 \
15 file://2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch \ 15 file://2011.09git/0001-am335x_evm-boot-kernel-from-ext2-3-filesystem.patch \
16 file://2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch \ 16 file://2011.09git/0002-am335x_evm-set-bootdelay-to-0.patch \
17 file://2011.09git/0003-am335x-evm-make-rootfs-RO-on-boot.patch \
17 " 18 "
18 19
19SRCREV = "456880b203bc44c025c374c98fa327b804a9cf64" 20SRCREV = "456880b203bc44c025c374c98fa327b804a9cf64"