summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-08-21 00:01:14 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-08-20 18:13:21 +0000
commite0b51996e0058d56e4b4186867ba62a1865a9ca9 (patch)
tree49e9fd789f9afe115a8f22e71fcf563e993d83a9 /recipes-bsp
parent86ce914746f3a72e4457e09a56cf91dff0f25c81 (diff)
downloadmeta-ti-e0b51996e0058d56e4b4186867ba62a1865a9ca9.tar.gz
ti-display-sharing-fw: remove deprecated firmware
Display sharing is not supported in K5.4+ and corresponding FW is now obsolete. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ti-display-sharing-fw/ti-display-sharing-fw_git.bb48
1 files changed, 0 insertions, 48 deletions
diff --git a/recipes-bsp/ti-display-sharing-fw/ti-display-sharing-fw_git.bb b/recipes-bsp/ti-display-sharing-fw/ti-display-sharing-fw_git.bb
deleted file mode 100644
index 9115b6b4..00000000
--- a/recipes-bsp/ti-display-sharing-fw/ti-display-sharing-fw_git.bb
+++ /dev/null
@@ -1,48 +0,0 @@
1SUMMARY = "TI Display Sharing Firmware"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PV = "06.01.00.00+git${SRCPV}"
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9inherit deploy
10inherit update-alternatives
11
12PROTOCOL = "git"
13BRANCH = "ti-linux-firmware"
14SRCREV = "e7be1ab85266c47236330e2909997d20fc62e312"
15
16SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=${PROTOCOL};branch=${BRANCH}"
17
18S = "${WORKDIR}/git"
19
20TI_DISP_SHARE_FW_DIR = "${S}/ti-display-sharing/"
21TI_DISP_SHARE_FW_FILENAME = "ti-display-sharing-j721e.bin"
22
23# make sure that lib/firmware, and all its contents are part of the package
24FILES_${PN} += "${base_libdir}/firmware"
25
26do_install() {
27 install -d ${D}${base_libdir}/firmware
28 install -m 0755 ${TI_DISP_SHARE_FW_DIR}/${TI_DISP_SHARE_FW_FILENAME} ${D}${base_libdir}/firmware
29}
30
31TARGET_MAIN_R5FSS0_1 = "j7-main-r5f0_1-fw"
32ALTERNATIVE_${PN} = "j7-main-r5f0_1-fw"
33ALTERNATIVE_LINK_NAME[j7-main-r5f0_1-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS0_1}"
34ALTERNATIVE_TARGET[j7-main-r5f0_1-fw] = "${base_libdir}/firmware/${TI_DISP_SHARE_FW_FILENAME}"
35ALTERNATIVE_PRIORITY = "9"
36
37# This is used to prevent the build system to strip the executables
38INHIBIT_PACKAGE_STRIP = "1"
39INHIBIT_SYSROOT_STRIP = "1"
40
41# This is used to prevent the build system to split the debug info in a separate file
42INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
43# As it likely to be a different arch from the Yocto build, disable checking by adding "arch" to INSANE_SKIP
44INSANE_SKIP_${PN} += "arch"
45
46# we don't want to configure and build the source code
47do_compile[noexec] = "1"
48do_configure[noexec] = "1"