diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-08 08:52:31 +0100 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-03-08 08:52:31 +0100 |
commit | f9e942c6b1c31f1fbb5e108b7f1fa859fd0f7412 (patch) | |
tree | ff83dfd7c32a0737534bd956f94182e8bb0c9271 /recipes-bsp/x-load | |
parent | e377e1378cd3e3421dc7d3c500a5f41b93fad64d (diff) | |
download | meta-ti-f9e942c6b1c31f1fbb5e108b7f1fa859fd0f7412.tar.gz |
x-load: fall back to xM when detecting beagleboard revisions
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp/x-load')
-rw-r--r-- | recipes-bsp/x-load/x-load/xmc.patch | 52 | ||||
-rw-r--r-- | recipes-bsp/x-load/x-load_git.bb | 3 |
2 files changed, 54 insertions, 1 deletions
diff --git a/recipes-bsp/x-load/x-load/xmc.patch b/recipes-bsp/x-load/x-load/xmc.patch new file mode 100644 index 00000000..bddcb8fc --- /dev/null +++ b/recipes-bsp/x-load/x-load/xmc.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | From b35937bf29c828e311f1d9bb1385bd32d34ec060 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jason Kridner <jkridner@beagleboard.org> | ||
3 | Date: Mon, 7 Mar 2011 19:31:15 -0600 | ||
4 | Subject: [PATCH] Forced newer revisions to default to xM. | ||
5 | |||
6 | --- | ||
7 | board/omap3530beagle/omap3530beagle.c | 15 ++++++++++++++- | ||
8 | 1 files changed, 14 insertions(+), 1 deletions(-) | ||
9 | |||
10 | diff --git a/board/omap3530beagle/omap3530beagle.c b/board/omap3530beagle/omap3530beagle.c | ||
11 | index 1b3d8c7..d55d32e 100644 | ||
12 | --- a/board/omap3530beagle/omap3530beagle.c | ||
13 | +++ b/board/omap3530beagle/omap3530beagle.c | ||
14 | @@ -212,6 +212,7 @@ u32 cpu_is_3410(void) | ||
15 | * GPIO173, GPIO172, GPIO171: 1 1 0 => C1/2/3 | ||
16 | * GPIO173, GPIO172, GPIO171: 1 0 1 => C4 | ||
17 | * GPIO173, GPIO172, GPIO171: 0 0 0 => XM | ||
18 | + * default => XM | ||
19 | ******************************************/ | ||
20 | int beagle_revision(void) | ||
21 | { | ||
22 | @@ -227,6 +228,18 @@ int beagle_revision(void) | ||
23 | rev = omap_get_gpio_datain(173) << 2 | | ||
24 | omap_get_gpio_datain(172) << 1 | | ||
25 | omap_get_gpio_datain(171); | ||
26 | + | ||
27 | + /* Default newer board revisions to XM */ | ||
28 | + switch(rev) { | ||
29 | + case REVISION_AXBX: | ||
30 | + case REVISION_CX: | ||
31 | + case REVISION_C4: | ||
32 | + break; | ||
33 | + case REVISION_XM: | ||
34 | + default: | ||
35 | + rev = REVISION_XM; | ||
36 | + } | ||
37 | + | ||
38 | omap_free_gpio(171); | ||
39 | omap_free_gpio(172); | ||
40 | omap_free_gpio(173); | ||
41 | @@ -662,7 +675,7 @@ int misc_init_r(void) | ||
42 | printf("Beagle Rev C4\n"); | ||
43 | break; | ||
44 | case REVISION_XM: | ||
45 | - printf("Beagle xM Rev A\n"); | ||
46 | + printf("Beagle xM\n"); | ||
47 | break; | ||
48 | default: | ||
49 | printf("Beagle unknown 0x%02x\n", rev); | ||
50 | -- | ||
51 | 1.6.1 | ||
52 | |||
diff --git a/recipes-bsp/x-load/x-load_git.bb b/recipes-bsp/x-load/x-load_git.bb index 5be261b7..eb8f3eaf 100644 --- a/recipes-bsp/x-load/x-load_git.bb +++ b/recipes-bsp/x-load/x-load_git.bb | |||
@@ -3,7 +3,7 @@ require x-load.inc | |||
3 | #FILESPATHPKG_prepend = "x-load-git:x-load-git/${MACHINE}" | 3 | #FILESPATHPKG_prepend = "x-load-git:x-load-git/${MACHINE}" |
4 | 4 | ||
5 | PV = "1.44+${PR}+gitr${SRCREV}" | 5 | PV = "1.44+${PR}+gitr${SRCREV}" |
6 | PR ="r20" | 6 | PR ="r21" |
7 | PE = "1" | 7 | PE = "1" |
8 | 8 | ||
9 | SRCREV_pn-${PN} = "24b8b7f41a83540433024854736518876257672c" | 9 | SRCREV_pn-${PN} = "24b8b7f41a83540433024854736518876257672c" |
@@ -13,6 +13,7 @@ SRC_URI = "git://gitorious.org/x-loader/x-loader.git;branch=master;protocol=git | |||
13 | file://0003-MUX-Configure-SYS_NIRQ2-pin-in-safe-mode.patch \ | 13 | file://0003-MUX-Configure-SYS_NIRQ2-pin-in-safe-mode.patch \ |
14 | file://0004-OMAP4-clocks-Disable-slimbus-and-pad_clks.patch \ | 14 | file://0004-OMAP4-clocks-Disable-slimbus-and-pad_clks.patch \ |
15 | file://0005-omap4-Make-1GHz-as-default-MPU-clock.patch \ | 15 | file://0005-omap4-Make-1GHz-as-default-MPU-clock.patch \ |
16 | file://xmc.patch \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | S = "${WORKDIR}/git" | 19 | S = "${WORKDIR}/git" |