summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/vpe-tests
diff options
context:
space:
mode:
authorNikhil Devshatwar <nikhil.nd@ti.com>2015-01-22 20:06:16 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-01-27 19:39:20 -0500
commit7cddc2a6d92d14164916d6cf303f4bdb38f47b4a (patch)
treee39b9ade886122fed854b33428e4b314fa1d0a69 /recipes-bsp/vpe-tests
parent82da11cf23abe9a1eac62a706549a9f0bd70dcf4 (diff)
downloadmeta-ti-7cddc2a6d92d14164916d6cf303f4bdb38f47b4a.tar.gz
vpdma-fw: Separate vpdma-fw and vpe-tests recipe
VPDMA firmware is published publicly as IPUMM firmware. This patch creates a separate recipe for VPDMA firmware. Also, it updates the package names in kernel dependencies. The vpe-tests is an independent recipe which can be included in the packagegroup if required. Signed-off-by: Nikhil Devshatwar <nikhil.nd@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/vpe-tests')
-rw-r--r--recipes-bsp/vpe-tests/vpe-tests_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/vpe-tests/vpe-tests_git.bb b/recipes-bsp/vpe-tests/vpe-tests_git.bb
new file mode 100644
index 00000000..a8ee7f89
--- /dev/null
+++ b/recipes-bsp/vpe-tests/vpe-tests_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "VPE test program"
2
3LICENSE = "BSD"
4LIC_FILES_CHKSUM = "file://COPYING;md5=74d2f71d8898c54e3d1c9d0058c484aa"
5
6COMPATIBLE_MACHINE = "dra7xx"
7
8SRCREV = "e3d8db1aa935775f9d196ad7428e0cd9864a36ca"
9BRANCH ?= "master"
10
11SRC_URI = "git://git.ti.com/vpe_tests/vpe_tests.git;protocol=git;branch=${BRANCH}"
12
13S = "${WORKDIR}/git"
14
15FLOATABI = "${@base_contains("TUNE_FEATURES", "vfp", base_contains("TUNE_FEATURES", "callconvention-hard", " -mfloat-abi=hard", " -mfloat-abi=softfp", d), "" ,d)}"
16
17# The test application needs additional include headers from the kernel
18EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${TARGET_PREFIX}gcc ${FLOATABI}" KDIR="${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"'
19
20do_install() {
21 oe_runmake DESTDIR="${D}" install
22}
23