summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/vis-fw
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2014-06-20 18:10:18 -0400
committerDenys Dmytriyenko <denys@ti.com>2014-06-23 17:57:05 -0400
commit4b79986d032bfd9cc40a7cf832de3e772a1e2e81 (patch)
tree9f4ec12248929a3cf24325dfbef7fb8948a0cc39 /recipes-bsp/vis-fw
parent171d3312e50793281d99f06d4248478d5777aa7c (diff)
downloadmeta-ti-4b79986d032bfd9cc40a7cf832de3e772a1e2e81.tar.gz
recipes: consolidate firmware recipes under recipes-bsp in own directories
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/vis-fw')
-rw-r--r--recipes-bsp/vis-fw/vis_01.50.07.15.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-bsp/vis-fw/vis_01.50.07.15.bb b/recipes-bsp/vis-fw/vis_01.50.07.15.bb
new file mode 100644
index 00000000..85d85397
--- /dev/null
+++ b/recipes-bsp/vis-fw/vis_01.50.07.15.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "Radio Application Firmware"
2LICENSE = "TI-TSPA"
3LIC_FILES_CHKSUM = "file://${S}/J6_VIS_DEMO_LINUX_BINARY_01.50.07.15-Manifest.html;md5=a59aa54b9470f555cf086b91dca0afa3"
4
5COMPATIBLE_MACHINE = "dra7xx-evm"
6PACKAGE_ARCH = "${MACHINE_ARCH}"
7
8SRC_URI = "http://downloads.ti.com/dsps/dsps_public_sw/glsdk/vis/01_50_07_15/exports/vis-${MACHINE}-01.50.07.15.tar.gz;protocol=http"
9
10SRC_URI[md5sum] = "fe8b00e398fb3b7ada0c15b601867acb"
11SRC_URI[sha256sum] = "6e2aa47ae892910616ebdc96646af778af9a59ca0657716ab4fa4b24a9afae69"
12
13S = "${WORKDIR}"
14
15DSPAPP = "dra7-dsp1-fw-radio.xe66"
16GPPAPP = "RadioApp"
17
18do_install() {
19 install -d ${D}${base_libdir}/firmware
20 install -d ${D}${bindir}
21 install ${S}/prebuilt/${DSPAPP} ${D}${base_libdir}/firmware/${DSPAPP}
22 install -m 0755 ${S}/prebuilt/${GPPAPP} ${D}${bindir}/${GPPAPP}
23}
24
25PACKAGES += "${PN}-fw"
26RDEPENDS_${PN} += "${PN}-fw"
27
28FILES_${PN}-fw += "${base_libdir}/firmware/${DSPAPP}"
29
30INSANE_SKIP_${PN}-fw = "arch"
31INHIBIT_PACKAGE_DEBUG_SPLIT = "1"