summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/utils-rtos/profiling-rtos_git.bb
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-07-19 05:03:25 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-22 16:03:53 -0400
commited04da4933f299fb905af2203d3fa8f4a1acde80 (patch)
treea6ad5e1ac450c0095890324e6169e78ce4b12742 /recipes-bsp/utils-rtos/profiling-rtos_git.bb
parent8db1e4dcb746bd80669c9f8f1b23ea070b50b182 (diff)
downloadmeta-ti-ed04da4933f299fb905af2203d3fa8f4a1acde80.tar.gz
profiling-rtos: Add rtos recipe for profiling
Upstreaming RTOS recipe for profiling utilties Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/utils-rtos/profiling-rtos_git.bb')
-rw-r--r--recipes-bsp/utils-rtos/profiling-rtos_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/utils-rtos/profiling-rtos_git.bb b/recipes-bsp/utils-rtos/profiling-rtos_git.bb
new file mode 100644
index 00000000..2afbef9d
--- /dev/null
+++ b/recipes-bsp/utils-rtos/profiling-rtos_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "TI RTOS profiling utilities"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://profilingver.h;beginline=1;endline=46;md5=974494ad60f33cfc0340e421c5a5a7a0"
7
8COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11PROFILING_GIT_URI = "git://git.ti.com/keystone-rtos/utils.git"
12PROFILING_GIT_PROTOCOL = "git"
13PROFILING_GIT_BRANCH = "master"
14
15# Below commit ID corresponds to "DEV.UTILS.01.00.00.04"
16PROFILING_SRCREV = "535ee56fcc6a476029d9567df49a5308b866efe4"
17
18BRANCH = "${PROFILING_GIT_BRANCH}"
19SRC_URI = "${PROFILING_GIT_URI};protocol=${PROFILING_GIT_PROTOCOL};branch=${BRANCH}"
20
21SRCREV = "${PROFILING_SRCREV}"
22PV = "01.00.00.04"
23PR = "r0"
24
25S = "${WORKDIR}/git/profiling"
26
27# Build with make instead of XDC
28TI_PDK_XDCMAKE = "0"
29
30export PDK_PROFILING_ROOT_PATH ="${WORKDIR}/build"
31export DEST_ROOT="${S}"
32
33# HTML doc link params
34PDK_COMP_LINK_TEXT = "Profiling Utility Library"