diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2017-07-19 05:03:35 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-09-01 12:50:33 -0400 |
commit | 6b6ca0c227312ff7a8655a2144d53cd5e0bc46c8 (patch) | |
tree | 4567f21c52ee299afe7a964d868531136294828f /recipes-bsp/usb-lld | |
parent | 35b23909e6e4c53a151f5a1d22f85776836017af (diff) | |
download | meta-ti-6b6ca0c227312ff7a8655a2144d53cd5e0bc46c8.tar.gz |
usb-lld-rtos: Added rtos recipe for usb-lld
Upstreaming RTOS low level driver for USB interface
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/usb-lld')
-rw-r--r-- | recipes-bsp/usb-lld/usb-lld-rtos_git.bb | 36 |
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/usb-lld/usb-lld-rtos_git.bb b/recipes-bsp/usb-lld/usb-lld-rtos_git.bb new file mode 100644 index 00000000..a227981d --- /dev/null +++ b/recipes-bsp/usb-lld/usb-lld-rtos_git.bb | |||
@@ -0,0 +1,36 @@ | |||
1 | SUMMARY = "TI RTOS USB low level driver" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | |||
5 | LICENSE = "BSD-3-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://USBver.h;beginline=16;endline=46;md5=5394fa32763383d2c8e2aca5a1c67805" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g" | ||
9 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
10 | |||
11 | USB_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/usb.git" | ||
12 | USB_LLD_GIT_PROTOCOL = "git" | ||
13 | USB_LLD_GIT_BRANCH = "master" | ||
14 | |||
15 | # Below commit ID corresponds to "DEV.USB_LLD.01.00.00.09" | ||
16 | USB_LLD_SRCREV = "6c2b21e5f6f8b34313f8d30a1de9b3e2fc301a73" | ||
17 | |||
18 | BRANCH = "${USB_LLD_GIT_BRANCH}" | ||
19 | SRC_URI = "${USB_LLD_GIT_URI};protocol=${USB_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
20 | |||
21 | SRCREV = "${USB_LLD_SRCREV}" | ||
22 | PV = "01.00.00.09" | ||
23 | PR = "r0" | ||
24 | |||
25 | DEPENDS_append = " osal-rtos" | ||
26 | DEPENDS_append_ti33x = " starterware-rtos" | ||
27 | DEPENDS_append_ti43x = " starterware-rtos" | ||
28 | |||
29 | # Build with make instead of XDC | ||
30 | TI_PDK_XDCMAKE = "0" | ||
31 | |||
32 | export PDK_USB_ROOT_PATH ="${WORKDIR}/build" | ||
33 | export DEST_ROOT="${S}" | ||
34 | |||
35 | # HTML doc link params | ||
36 | PDK_COMP_LINK_TEXT = "USB LLD" | ||