diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-09-01 07:34:54 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-09-02 09:44:31 -0400 |
commit | c81c6a7dc2b09e5c69ee6f129db55b620851b855 (patch) | |
tree | 3fbf2c2c77b7fb951d4422b51c9a4ba5b30d7370 /recipes-bsp/uio-module-drv | |
parent | 404eb49c6252c2c25c1d2c035cbe7307670b89aa (diff) | |
download | meta-ti-c81c6a7dc2b09e5c69ee6f129db55b620851b855.tar.gz |
uio-module-drv: Update to new version 1.0.2.3
- Also add test code recipe for uio-module-drv
- Common part of recipe moved to uio-module-drv.inc
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/uio-module-drv')
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb | 16 | ||||
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv.inc | 10 | ||||
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv_git.bb | 13 |
3 files changed, 28 insertions, 11 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb new file mode 100644 index 00000000..1080a916 --- /dev/null +++ b/recipes-bsp/uio-module-drv/uio-module-drv-test_git.bb | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "Test code for user space IO (UIO) driver" | ||
2 | |||
3 | include uio-module-drv.inc | ||
4 | PV = "1.0.2.3" | ||
5 | |||
6 | COMPATIBLE_MACHINE = "keystone" | ||
7 | RDEPENDS_${PN} = "uio-module-drv" | ||
8 | |||
9 | do_compile() { | ||
10 | oe_runmake -C ${S} test | ||
11 | } | ||
12 | |||
13 | do_install() { | ||
14 | install -d ${D}${bindir}/ | ||
15 | install -c -m 755 ${S}/test/uio_cic2_int_multithread_test ${D}${bindir}/. | ||
16 | } | ||
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv.inc b/recipes-bsp/uio-module-drv/uio-module-drv.inc new file mode 100644 index 00000000..567f7f65 --- /dev/null +++ b/recipes-bsp/uio-module-drv/uio-module-drv.inc | |||
@@ -0,0 +1,10 @@ | |||
1 | LICENSE = "BSD" | ||
2 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" | ||
3 | |||
4 | BRANCH = "master" | ||
5 | # This corresponds to version 01.00.02.03 | ||
6 | SRCREV = "634a0c64763c5cd7840e2d439d0ee900455584c8" | ||
7 | |||
8 | SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb index b2475278..d75fda2c 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb +++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb | |||
@@ -1,21 +1,12 @@ | |||
1 | DESCRIPTION="User space IO (UIO) driver for on-chip modules" | 1 | DESCRIPTION="User space IO (UIO) driver for on-chip modules" |
2 | 2 | ||
3 | LICENSE = "BSD" | 3 | include uio-module-drv.inc |
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" | 4 | PV = "1.0.2.3+git${SRCPV}" |
5 | |||
6 | BRANCH ?= "master" | ||
7 | # This corresponds to version 01.00.02.01 | ||
8 | SRCREV = "c1988446e3364af4df7cd877e6536f0c6647d7bb" | ||
9 | PV = "1.0.2.1+git${SRCPV}" | ||
10 | |||
11 | SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" | ||
12 | 5 | ||
13 | # This package builds a kernel module, use kernel PR as base and append a local | 6 | # This package builds a kernel module, use kernel PR as base and append a local |
14 | MACHINE_KERNEL_PR_append = "b" | 7 | MACHINE_KERNEL_PR_append = "b" |
15 | PR = "${MACHINE_KERNEL_PR}" | 8 | PR = "${MACHINE_KERNEL_PR}" |
16 | 9 | ||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | module_auto_load_uio-module-drv = "uio-module-drv" | 10 | module_auto_load_uio-module-drv = "uio-module-drv" |
20 | 11 | ||
21 | inherit module | 12 | inherit module |