diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-12-01 00:40:45 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-30 16:46:03 -0500 |
commit | 77c46bc3170892cc55d5f92e0ab00c2920ef9097 (patch) | |
tree | 2150515e1731e1f2e13bba618fa08dd8cfc78121 /recipes-bsp/uio-module-drv | |
parent | 46f20bb8d4352f102f38de327ec7b38d521ee3a9 (diff) | |
download | meta-ti-77c46bc3170892cc55d5f92e0ab00c2920ef9097.tar.gz |
uio-module-drv: Update to new version 2.0.0.0_eng
- Update to eng release 2.0.0.0
- Added install append for new API header file
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/uio-module-drv')
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv.inc | 6 | ||||
-rw-r--r-- | recipes-bsp/uio-module-drv/uio-module-drv_git.bb | 7 |
2 files changed, 9 insertions, 4 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv.inc b/recipes-bsp/uio-module-drv/uio-module-drv.inc index 567f7f65..ed34a8ab 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv.inc +++ b/recipes-bsp/uio-module-drv/uio-module-drv.inc | |||
@@ -1,9 +1,9 @@ | |||
1 | LICENSE = "BSD" | 1 | LICENSE = "BSD" |
2 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" | 2 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2b7c96eb2aed7b0f6f922214dbde9016" |
3 | 3 | ||
4 | BRANCH = "master" | 4 | BRANCH = "linux4.1" |
5 | # This corresponds to version 01.00.02.03 | 5 | # This corresponds to version 02.00.00.00_eng |
6 | SRCREV = "634a0c64763c5cd7840e2d439d0ee900455584c8" | 6 | SRCREV = "6a7eda36e390658593a5b8d87b0f00beb3997240" |
7 | 7 | ||
8 | SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" | 8 | SRC_URI = "git://git.ti.com/keystone-linux/uio-module-drv.git;protocol=git;branch=${BRANCH}" |
9 | 9 | ||
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb index d75fda2c..445dc1c6 100644 --- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb +++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb | |||
@@ -1,7 +1,7 @@ | |||
1 | DESCRIPTION="User space IO (UIO) driver for on-chip modules" | 1 | DESCRIPTION="User space IO (UIO) driver for on-chip modules" |
2 | 2 | ||
3 | include uio-module-drv.inc | 3 | include uio-module-drv.inc |
4 | PV = "1.0.2.3+git${SRCPV}" | 4 | PV = "2.0.0.0+git${SRCPV}" |
5 | 5 | ||
6 | # This package builds a kernel module, use kernel PR as base and append a local | 6 | # This package builds a kernel module, use kernel PR as base and append a local |
7 | MACHINE_KERNEL_PR_append = "b" | 7 | MACHINE_KERNEL_PR_append = "b" |
@@ -10,3 +10,8 @@ PR = "${MACHINE_KERNEL_PR}" | |||
10 | module_auto_load_uio-module-drv = "uio-module-drv" | 10 | module_auto_load_uio-module-drv = "uio-module-drv" |
11 | 11 | ||
12 | inherit module | 12 | inherit module |
13 | |||
14 | do_install_append () { | ||
15 | install -d ${D}${includedir} | ||
16 | cp *.h ${D}${includedir} | ||
17 | } | ||