summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/uio-module-drv
diff options
context:
space:
mode:
authorPraneeth Bajjuri <praneeth@ti.com>2021-04-22 12:37:22 +0000
committerPraneeth Bajjuri <praneeth@ti.com>2021-04-22 16:49:55 -0500
commit3bd1551585295fb205c3b811346f8921daf5c9bb (patch)
tree0c34569dcb05f681f9804fc4c5227522baac4c76 /recipes-bsp/uio-module-drv
parentb08909657506aad416f382b2506e54e169dc78f6 (diff)
downloadmeta-ti-3bd1551585295fb205c3b811346f8921daf5c9bb.tar.gz
uio-module-drv: Build fix for linux kernel 5.10
This update contains build fix for linux kernel 5.10 * uio-module-drv: Replace ioremap_nocache with ioremap Signed-off-by: Praneeth Bajjuri <praneeth@ti.com> Reviewed-by: Gowtham Tammana <g-tammana@ti.com>
Diffstat (limited to 'recipes-bsp/uio-module-drv')
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch35
-rw-r--r--recipes-bsp/uio-module-drv/uio-module-drv_git.bb4
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch b/recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch
new file mode 100644
index 00000000..955ef558
--- /dev/null
+++ b/recipes-bsp/uio-module-drv/uio-module-drv/0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch
@@ -0,0 +1,35 @@
1From b5c4036dac06817bffd0be21c5fa1b7f75f74e4b Mon Sep 17 00:00:00 2001
2From: Suman Anna <s-anna@ti.com>
3Date: Mon, 19 Apr 2021 13:15:51 -0500
4Subject: [PATCH] uio-module-drv: Replace ioremap_nocache with ioremap
5
6The ioremap_nocache is the same as the regular ioremap and its
7definition has been dropped from the Linux kernel v5.6 onwards in
8commit 4bdc0d676a64 ("remove ioremap_nocache and devm_ioremap_nocache")
9[1]. The uio-module-drv module fails to build against these newer
10kernels, so fix it by simply replacing ioremap_nocache with ioremap.
11
12[1]
13https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=4bdc0d676a643140bdf17dbf7eafedee3d496a3c
14
15Signed-off-by: Suman Anna <s-anna@ti.com>
16---
17 uio_module_drv.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/uio_module_drv.c b/uio_module_drv.c
21index 5a67dd199e21..7cc6005d1f05 100644
22--- a/uio_module_drv.c
23+++ b/uio_module_drv.c
24@@ -240,7 +240,7 @@ static ssize_t uio_module_drv_transfer(struct file *file, char __user *buf,
25 return -EINVAL;
26 }
27
28- virt_addr_p = ioremap_nocache(phys_addr, count);
29+ virt_addr_p = ioremap(phys_addr, count);
30 if (!virt_addr_p) {
31 dev_err(uio_module_drv->dev, "Mapping of virtual memory failed\n");
32 return(-ENOMEM);
33--
342.30.1
35
diff --git a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
index 6ac91875..cb61305f 100644
--- a/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
+++ b/recipes-bsp/uio-module-drv/uio-module-drv_git.bb
@@ -2,6 +2,10 @@ DESCRIPTION = "User space IO (UIO) driver for on-chip modules"
2 2
3include uio-module-drv.inc 3include uio-module-drv.inc
4 4
5FILESEXTRAPATHS_prepend:= "${THISDIR}/${PN}:"
6
7SRC_URI += "file://0001-uio-module-drv-Replace-ioremap_nocache-with-ioremap.patch"
8
5# This package builds a kernel module, use kernel PR as base and append a local 9# This package builds a kernel module, use kernel PR as base and append a local
6MACHINE_KERNEL_PR_append = "d" 10MACHINE_KERNEL_PR_append = "d"
7PR = "${MACHINE_KERNEL_PR}" 11PR = "${MACHINE_KERNEL_PR}"