summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2019-02-07 06:42:42 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-02-07 03:50:48 +0000
commit8c44d9161ce218af78972ca1ce356ac9aa840e1e (patch)
tree41e855a4cc5ad9b83cd388975d8bb1bd9e835475 /recipes-bsp/u-boot
parent2f28749040692b2267cb72303365bf3d2a391fef (diff)
downloadmeta-ti-8c44d9161ce218af78972ca1ce356ac9aa840e1e.tar.gz
u-boot-ti-staging: update to 2019.01
License checksum changed due to extra SPDX lines - no actual license change. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/files/0001-Always-build-with-fno-PIE.patch35
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2018.01.bb9
-rw-r--r--recipes-bsp/u-boot/u-boot-ti-staging_2019.01.bb7
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc4
4 files changed, 9 insertions, 46 deletions
diff --git a/recipes-bsp/u-boot/files/0001-Always-build-with-fno-PIE.patch b/recipes-bsp/u-boot/files/0001-Always-build-with-fno-PIE.patch
deleted file mode 100644
index dfd99c66..00000000
--- a/recipes-bsp/u-boot/files/0001-Always-build-with-fno-PIE.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From ec81bbe3ea7e077512f4b9d2b4aa87e7f1494bcc Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 17 Oct 2018 22:32:57 -0700
4Subject: [PATCH] Always build with -fno-PIE
5
6GNU Toolchains can be configured to generate PIE by default
7while PIE could be ok, it is known that u-boot/SPL on ARM starts to
8generate bigger code and starts to overflow the SRAM size, therefore
9disabling PIE explcitly insulates against toolchain intrinsic defaults
10
11Fixes errors like
12| arm-yoe-linux-gnueabi-ld.bfd: u-boot-spl section `.rodata' will not fit in region `.sram'
13| arm-yoe-linux-gnueabi-ld.bfd: region `.sram' overflowed by 5772 bytes
14
15Signed-off-by: Khem Raj <raj.khem@gmail.com>
16Cc: Tom Rini <trini@konsulko.com>
17---
18 Makefile | 1 +
19 1 file changed, 1 insertion(+)
20
21diff --git a/Makefile b/Makefile
22index 45cd751ba3..9eb8ac564e 100644
23--- a/Makefile
24+++ b/Makefile
25@@ -592,6 +592,7 @@ KBUILD_CFLAGS += -O2
26 endif
27
28 KBUILD_CFLAGS += $(call cc-option,-fno-stack-protector)
29+KBUILD_CFLAGS += $(call cc-option,-fno-PIE)
30 KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks)
31
32 KBUILD_CFLAGS += -g
33--
342.19.1
35
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2018.01.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2018.01.bb
deleted file mode 100644
index d458dc9c..00000000
--- a/recipes-bsp/u-boot/u-boot-ti-staging_2018.01.bb
+++ /dev/null
@@ -1,9 +0,0 @@
1require u-boot-ti.inc
2
3PR = "r30"
4
5BRANCH = "ti-u-boot-2018.01"
6
7SRCREV = "313dcd69c2b32648266f91bcf223f9e539bc4201"
8
9SRC_URI += "file://0001-Always-build-with-fno-PIE.patch"
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2019.01.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2019.01.bb
new file mode 100644
index 00000000..a890b82e
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ti-staging_2019.01.bb
@@ -0,0 +1,7 @@
1require u-boot-ti.inc
2
3PR = "r0"
4
5BRANCH = "ti-u-boot-2019.01"
6
7SRCREV = "721a0ba045e97f4532718d38ed6941eb9a167225"
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index 62f04f7c..9d827117 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -20,7 +20,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
20SUMMARY = "u-boot bootloader for TI devices" 20SUMMARY = "u-boot bootloader for TI devices"
21 21
22LICENSE = "GPLv2+" 22LICENSE = "GPLv2+"
23LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" 23LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
24 24
25BRANCH ?= "master" 25BRANCH ?= "master"
26UBOOT_GIT_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git" 26UBOOT_GIT_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git"
@@ -30,7 +30,7 @@ SRC_URI = "${UBOOT_GIT_URI};protocol=${UBOOT_GIT_PROTOCOL};branch=${BRANCH}"
30PV_append = "+git${SRCPV}" 30PV_append = "+git${SRCPV}"
31 31
32# u-boot needs devtree compiler to parse dts files 32# u-boot needs devtree compiler to parse dts files
33DEPENDS += "dtc-native bc-native lzop-native" 33DEPENDS += "dtc-native bc-native lzop-native flex-native bison-native"
34 34
35PACKAGECONFIG[atf] = "ATF=${STAGING_DIR_HOST}/boot/bl31.bin,,arm-trusted-firmware" 35PACKAGECONFIG[atf] = "ATF=${STAGING_DIR_HOST}/boot/bl31.bin,,arm-trusted-firmware"
36PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}/boot/bl32.bin,,optee-os" 36PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}/boot/bl32.bin,,optee-os"