summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-02 16:50:43 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-03 09:01:08 +0100
commit13a25a08f2d3b6b00d0cf33855978b215390e710 (patch)
treee335843faca564f5b4e4a43e3696a16d13c5a902 /recipes-bsp/u-boot
parent60f1c4f27eb8d791dc7cc1e21ead3a7749d2d15c (diff)
downloadmeta-ti-13a25a08f2d3b6b00d0cf33855978b215390e710.tar.gz
TI BSP: add support the OMAP35x EVM board
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot/0001-omap3evm-Change-default-console-serial-port-from.patch30
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb15
2 files changed, 41 insertions, 4 deletions
diff --git a/recipes-bsp/u-boot/u-boot/0001-omap3evm-Change-default-console-serial-port-from.patch b/recipes-bsp/u-boot/u-boot/0001-omap3evm-Change-default-console-serial-port-from.patch
new file mode 100644
index 00000000..d171b78a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/0001-omap3evm-Change-default-console-serial-port-from.patch
@@ -0,0 +1,30 @@
1From 6b23ecf49d1c2ee5227ff57101919af46ecd7396 Mon Sep 17 00:00:00 2001
2From: Roger Monk <r-monk@ti.com>
3Date: Fri, 9 Jul 2010 08:37:04 +0100
4Subject: [PATCH] omap3evm: Change default 'console' serial port from ttyS2 to ttyS0
5
6 * Update default kernel console env variable ($(console))
7 to use ttyS0 (instead of ttyS2) to match the serial port
8 used by x-loader and u-boot
9
10Signed-off-by: Roger Monk <r-monk@ti.com>
11---
12 include/configs/omap3_evm.h | 2 +-
13 1 files changed, 1 insertions(+), 1 deletions(-)
14
15diff --git a/include/configs/omap3_evm.h b/include/configs/omap3_evm.h
16index 73a5c98..d01d733 100644
17--- a/include/configs/omap3_evm.h
18+++ b/include/configs/omap3_evm.h
19@@ -203,7 +203,7 @@
20 #define CONFIG_EXTRA_ENV_SETTINGS \
21 "loadaddr=0x82000000\0" \
22 "usbtty=cdc_acm\0" \
23- "console=ttyS2,115200n8\0" \
24+ "console=ttyS0,115200n8\0" \
25 "mmcargs=setenv bootargs console=${console} " \
26 "root=/dev/mmcblk0p2 rw " \
27 "rootfstype=ext3 rootwait\0" \
28--
291.6.0.4
30
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index 37508630..3aa69b77 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -3,7 +3,7 @@ PR ="r65"
3 3
4FILESPATHPKG =. "u-boot-git:" 4FILESPATHPKG =. "u-boot-git:"
5 5
6SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \ 6SRC_URI_beagleboard = "git://www.denx.de/git/u-boot.git;protocol=git \
7 file://0001-OMAP3-enable-i2c-bus-switching-for-Beagle-and-Overo.patch \ 7 file://0001-OMAP3-enable-i2c-bus-switching-for-Beagle-and-Overo.patch \
8 file://0002-OMAP3-add-board-revision-detection-for-Overo.patch \ 8 file://0002-OMAP3-add-board-revision-detection-for-Overo.patch \
9 file://0003-OMAP3-update-Beagle-revision-detection-to-recognize-.patch \ 9 file://0003-OMAP3-update-Beagle-revision-detection-to-recognize-.patch \
@@ -53,10 +53,17 @@ SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
53 file://0044-Beagleboard-Adjust-boot.patch \ 53 file://0044-Beagleboard-Adjust-boot.patch \
54 file://0045-BeagleBoard-Enable-pullups-on-i2c2.patch \ 54 file://0045-BeagleBoard-Enable-pullups-on-i2c2.patch \
55 file://0046-BeagleBoard-Add-camera-to-default-bootargs.patch \ 55 file://0046-BeagleBoard-Add-camera-to-default-bootargs.patch \
56 file://0001-BeagleBoard-move-ramdisk-parameters.patch \ 56 file://0001-BeagleBoard-move-ramdisk-parameters.patch \
57 file://fw_env.config \ 57 file://fw_env.config \
58" 58"
59SRCREV = "ca6e1c136ddb720c3bb2cc043b99f7f06bc46c55" 59SRCREV_beagleboard = "ca6e1c136ddb720c3bb2cc043b99f7f06bc46c55"
60PV = "2010.03+${PR}+gitr${SRCREV}" 60PV_beagleboard = "2010.03+${PR}+gitr${SRCREV}"
61
62# ~ TI PSP v2009.11_OMAPPSP_03.00.01.06 (+ couple of commits)
63SRC_URI_omap3evm = "git://arago-project.org/git/projects/u-boot-omap3.git;protocol=git \
64 file://0001-omap3evm-Change-default-console-serial-port-from.patch \
65"
66SRCREV_omap3evm = "c0a8fb217fdca7888d89f9a3dee74a4cec865620"
67PV_omap3evm = "2009.11+${PR}+gitr${SRCREV}"
61 68
62S = "${WORKDIR}/git" 69S = "${WORKDIR}/git"