summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorPeter A. Bigot <bigotp@acm.org>2011-12-29 05:27:38 -0600
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-29 15:44:26 +0100
commit845be4c1d38ad5972bc2e62282484e4af5f5332b (patch)
tree1a525a683a910da03fab3fb6778659b9e1913ec0 /recipes-bsp/u-boot
parent97dc8eee974565c6a480528be530171515634256 (diff)
downloadmeta-ti-845be4c1d38ad5972bc2e62282484e4af5f5332b.tar.gz
u-boot 2011.12: OMAP MMC: Add delay before waiting for status
Pending upstream patch from http://patchwork.ozlabs.org/patch/132795/ is required to successfully boot on xM. Signed-off-by: Peter A. Bigot <bigotp@acm.org> Acked-by: Tom Rini <tom.rini@gmail.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/U-Boot-OMAP-MMC-Add-delay-before-waiting-for-status.patch45
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.12.bb3
2 files changed, 47 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/U-Boot-OMAP-MMC-Add-delay-before-waiting-for-status.patch b/recipes-bsp/u-boot/u-boot/2011.12/U-Boot-OMAP-MMC-Add-delay-before-waiting-for-status.patch
new file mode 100644
index 00000000..b334639f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/U-Boot-OMAP-MMC-Add-delay-before-waiting-for-status.patch
@@ -0,0 +1,45 @@
1From patchwork Thu Dec 22 09:56:35 2011
2Content-Type: text/plain; charset="utf-8"
3MIME-Version: 1.0
4Content-Transfer-Encoding: 8bit
5Subject: [U-Boot] OMAP MMC: Add delay before waiting for status
6Date: Wed, 21 Dec 2011 23:56:35 -0000
7From: =?utf-8?q?Andreas_M=C3=BCller_=3Cschnitzeltony=40gmx=2Ede=3E?=
8X-Patchwork-Id: 132795
9Message-Id: <1324547795-19678-1-git-send-email-schnitzeltony@gmx.de>
10To: u-boot@lists.denx.de
11
12Loading kernel from MMC created the following error message reproducable:
13
14| reading uImage
15| mmc_send_cmd: timedout waiting for stat!
16|
17| 2860468 bytes read
18
19Tested on overo with OMAP3530:
20* OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 720 mHz
21 Die ID #470e000400000000040398d31402100c
22* OMAP3530-GP ES3.1, CPU-OPP2, L3-165MHz, Max CPU Clock 600 mHz
23 Die ID #112000040000000004035c140101b011
24
25Signed-off-by: Andreas Müller <schnitzeltony@gmx.de>
26
27---
28drivers/mmc/omap_hsmmc.c | 4 ++++
29 1 files changed, 4 insertions(+), 0 deletions(-)
30
31diff --git a/drivers/mmc/omap_hsmmc.c b/drivers/mmc/omap_hsmmc.c
32index c38b9e6..ac91e5d 100644
33--- a/drivers/mmc/omap_hsmmc.c
34+++ b/drivers/mmc/omap_hsmmc.c
35@@ -197,6 +197,10 @@ static int mmc_send_cmd(struct mmc *mmc, struct mmc_cmd *cmd,
36 unsigned int flags, mmc_stat;
37 ulong start;
38
39+ /* Delay added before checking the status */
40+ if (cmd->cmdidx == MMC_CMD_SEND_STATUS)
41+ udelay(1); /* wait 1 us */
42+
43 start = get_timer(0);
44 while ((readl(&mmc_base->pstate) & DATI_MASK) == DATI_CMDDIS) {
45 if (get_timer(0) - start > MAX_RETRY_MS) {
diff --git a/recipes-bsp/u-boot/u-boot_2011.12.bb b/recipes-bsp/u-boot/u-boot_2011.12.bb
index 5a19066f..d776c38c 100644
--- a/recipes-bsp/u-boot/u-boot_2011.12.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.12.bb
@@ -6,7 +6,7 @@ UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
6UBOOT_SYMLINK = "u-boot-${MACHINE}.img" 6UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
7 7
8PV = "2011.12" 8PV = "2011.12"
9PR = "r0" 9PR = "r1"
10 10
11# No patches for other machines yet 11# No patches for other machines yet
12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)" 12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)"
@@ -17,6 +17,7 @@ SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
17 file://2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch \ 17 file://2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch \
18 file://2011.12/0004-omap4-common-mount-root-RO.patch \ 18 file://2011.12/0004-omap4-common-mount-root-RO.patch \
19 file://2011.12/0005-omap4-common-use-ext4-by-default.patch \ 19 file://2011.12/0005-omap4-common-use-ext4-by-default.patch \
20 file://2011.12/U-Boot-OMAP-MMC-Add-delay-before-waiting-for-status.patch \
20 " 21 "
21 22
22# v2011.12 tag 23# v2011.12 tag