diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-09-27 13:03:06 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-08 21:09:00 +0200 |
commit | dd497f403f25932aac22c6db5b98443bf3decda9 (patch) | |
tree | 6955ae1d63ec0f3f4660c047c219198e2d0cdc12 /recipes-bsp/u-boot | |
parent | 64ee1c77f6e9f007ee79ac02e25a4313995c111d (diff) | |
download | meta-ti-dd497f403f25932aac22c6db5b98443bf3decda9.tar.gz |
u-boot: add 2011.09+git for beaglebone 1st and 2nd stage
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r-- | recipes-bsp/u-boot/u-boot.inc | 1 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch | 26 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot_2011.10rc.bb | 25 |
3 files changed, 52 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot.inc b/recipes-bsp/u-boot/u-boot.inc index f9dab47e..310d80ca 100644 --- a/recipes-bsp/u-boot/u-boot.inc +++ b/recipes-bsp/u-boot/u-boot.inc | |||
@@ -64,4 +64,5 @@ do_deploy () { | |||
64 | 64 | ||
65 | cd ${DEPLOY_DIR_IMAGE} | 65 | cd ${DEPLOY_DIR_IMAGE} |
66 | rm -f ${UBOOT_SYMLINK} | 66 | rm -f ${UBOOT_SYMLINK} |
67 | ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK} | ||
67 | } | 68 | } |
diff --git a/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch b/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch new file mode 100644 index 00000000..af7fae72 --- /dev/null +++ b/recipes-bsp/u-boot/u-boot/0001-am335x-evm-hack-in-ethernet-rmii-clock.patch | |||
@@ -0,0 +1,26 @@ | |||
1 | From 5db18d5efdbdcd52ab33e28929a30f743a202bf8 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Fri, 7 Oct 2011 18:17:50 +0200 | ||
4 | Subject: [PATCH] am335x-evm: hack in ethernet rmii clock | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | include/configs/am335x_evm.h | 2 +- | ||
9 | 1 files changed, 1 insertions(+), 1 deletions(-) | ||
10 | |||
11 | diff --git a/include/configs/am335x_evm.h b/include/configs/am335x_evm.h | ||
12 | index 543c604..0f806aa 100755 | ||
13 | --- a/include/configs/am335x_evm.h | ||
14 | +++ b/include/configs/am335x_evm.h | ||
15 | @@ -163,7 +163,7 @@ | ||
16 | "bootm ${loadaddr}\0" \ | ||
17 | |||
18 | #define CONFIG_BOOTCOMMAND \ | ||
19 | - "if mmc rescan; then " \ | ||
20 | + "mw.l 0x44e10650 0x05 ; if mmc rescan; then " \ | ||
21 | "if run loadbootscript; then " \ | ||
22 | "run bootscript; " \ | ||
23 | "else " \ | ||
24 | -- | ||
25 | 1.6.6.1 | ||
26 | |||
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb new file mode 100644 index 00000000..9aebb1bc --- /dev/null +++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | require u-boot.inc | ||
2 | |||
3 | # No patches for other machines yet | ||
4 | COMPATIBLE_MACHINE = "beaglebone" | ||
5 | DEFAULT_PREFERENCE_beaglebone = "99" | ||
6 | PV = "2011.09+git" | ||
7 | PR = "r2" | ||
8 | |||
9 | # SPL build | ||
10 | UBOOT_BINARY = "u-boot.img" | ||
11 | UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img" | ||
12 | UBOOT_SYMLINK = "u-boot-${MACHINE}.img" | ||
13 | |||
14 | SRC_URI = "git://github.com/joelagnel/u-boot.git;protocol=git;branch=bone-bringup \ | ||
15 | file://0001-am335x-evm-hack-in-ethernet-rmii-clock.patch \ | ||
16 | " | ||
17 | SRCREV = "d643e691ab2055ef64f73dd70300a73e0443d1ef" | ||
18 | |||
19 | LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb" | ||
20 | |||
21 | S = "${WORKDIR}/git" | ||
22 | |||
23 | do_deploy_append () { | ||
24 | install ${S}/MLO ${DEPLOY_DIR_IMAGE}/MLO | ||
25 | } | ||