summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorJoel A Fernandes <joelagnel@ti.com>2011-11-04 14:26:03 -0500
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-04 23:40:18 +0100
commit67ad848beb9d6657e25263e029ad5471bbe36281 (patch)
treed84b08026e15390c8a70c4619ff922288edd8357 /recipes-bsp/u-boot
parent6a40735515b716c5c6c455bc3b45082f8a1a7594 (diff)
downloadmeta-ti-67ad848beb9d6657e25263e029ad5471bbe36281.tar.gz
U-boot 2011.10rc: Refresh PMIC patch with Rev A1 fixes
Signed-off-by: Joel A Fernandes <joelagnel@ti.com> Acked-by: Tom Rini <trini@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch51
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb2
2 files changed, 34 insertions, 19 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch
index 2b8caa36..158483b2 100644
--- a/recipes-bsp/u-boot/u-boot/2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0006-am335x-evm-Fix-bone-pmic-shut-down-over-USB-power.patch
@@ -1,33 +1,46 @@
1From 801316091ac7e14cc8fa9b0bd2cdce76bea06991 Mon Sep 17 00:00:00 2001 1From 801316091ac7e14cc8fa9b0bd2cdce76bea06991 Mon Sep 17 00:00:00 2001
2From: Joel A Fernandes <joelagnel@ti.com> 2From: Joel A Fernandes <joelagnel@ti.com>
3Date: Thu, 3 Nov 2011 22:19:19 -0500 3Date: Thu, 3 Nov 2011 22:19:19 -0500
4Subject: [PATCH] am335x-evm: Fix bone pmic shut down over USB power 4Subject: [PATCH v2] am335x-evm: Fix bone pmic shut down over USB power
5Cc: trini@ti.com 5Cc: trini@ti.com,
6 chase.maupin@ti.com
6 7
7* Set DCDC2 to 1.2v for all boards irrespective of board version, or power source. 8* Set DCDC2 to 1.2v for all power sources and board revs except for A1
8* Set USB current trip point to 1300mA for all boards and power sources. 9* Set USB current trip point to 1300mA for all boards and power sources.
9* Only Skip setting of MPU frequency to 720MHz for A1 and USB-powered boards. 10* Only Skip setting of MPU frequency to 720MHz for A1 and USB-powered boards.
10 11
11Credits to Jason for noticing this. Tested with 20 reboots over USB. 12Credits to Jason for noticing this. Tested with several reboots over USB on a Rev A2/3.
13
14v2 changes:
15Take care of not upping DCDC2 and LDO voltages for A1.
16For A1- only operation done is to set the USB current limit.
12 17
13Signed-off-by: Jason Kridner <jdk@ti.com> 18Signed-off-by: Jason Kridner <jdk@ti.com>
14Signed-off-by: Joel A Fernandes <joelagnel@ti.com> 19Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
15--- 20---
16 board/ti/am335x/evm.c | 27 ++++++++++++++------------- 21Chase has volunteered to test this out on his A1.
17 1 files changed, 14 insertions(+), 13 deletions(-) 22
23 board/ti/am335x/evm.c | 31 ++++++++++++++++---------------
24 1 files changed, 16 insertions(+), 15 deletions(-)
18 25
19diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c 26diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c
20index e95a088..bd3c09a 100644 27index e95a088..bc1119e 100644
21--- a/board/ti/am335x/evm.c 28--- a/board/ti/am335x/evm.c
22+++ b/board/ti/am335x/evm.c 29+++ b/board/ti/am335x/evm.c
23@@ -483,12 +483,10 @@ void spl_board_init(void) 30@@ -483,12 +483,20 @@ void spl_board_init(void)
24 if (tps65217_reg_read(STATUS, &pmic_status_reg)) 31 if (tps65217_reg_read(STATUS, &pmic_status_reg))
25 return; 32 return;
26 33
27- /* Only perform PMIC configurations if board rev > A1 */ 34+ /* Increase USB current limit to 1300mA */
28- if (!strncmp(header.version, "00A1", 4)) 35+ if (tps65217_reg_write(PROT_LEVEL_NONE, POWER_PATH,
29- return; 36+ USB_INPUT_CUR_LIMIT_1300MA,
30- 37+ USB_INPUT_CUR_LIMIT_MASK))
38+ printf("tps65217_reg_write failure\n");
39+
40 /* Only perform PMIC configurations if board rev > A1 */
41 if (!strncmp(header.version, "00A1", 4))
42 return;
43
31- if (!(pmic_status_reg & PWR_SRC_AC_BITMASK)) { 44- if (!(pmic_status_reg & PWR_SRC_AC_BITMASK)) {
32- printf("No AC power, disabling frequency switch\n"); 45- printf("No AC power, disabling frequency switch\n");
33+ /* Set DCDC2 (MPU) voltage to 1.275V */ 46+ /* Set DCDC2 (MPU) voltage to 1.275V */
@@ -37,10 +50,16 @@ index e95a088..bd3c09a 100644
37 return; 50 return;
38 } 51 }
39 52
40@@ -507,14 +505,17 @@ void spl_board_init(void) 53@@ -501,20 +509,13 @@ void spl_board_init(void)
41 USB_INPUT_CUR_LIMIT_MASK)) 54 LDO_VOLTAGE_OUT_3_3, LDO_MASK))
42 printf("tps65217_reg_write failure\n"); 55 printf("tps65217_reg_write failure\n");
43 56
57- /* Increase USB current limit to 1300mA */
58- if (tps65217_reg_write(PROT_LEVEL_NONE, POWER_PATH,
59- USB_INPUT_CUR_LIMIT_1300MA,
60- USB_INPUT_CUR_LIMIT_MASK))
61- printf("tps65217_reg_write failure\n");
62-
44- /* Set DCDC2 (MPU) voltage to 1.275V */ 63- /* Set DCDC2 (MPU) voltage to 1.275V */
45- if (!tps65217_voltage_update(DEFDCDC2, 64- if (!tps65217_voltage_update(DEFDCDC2,
46- DCDC_VOLT_SEL_1275MV)) { 65- DCDC_VOLT_SEL_1275MV)) {
@@ -48,10 +67,6 @@ index e95a088..bd3c09a 100644
48- mpu_pll_config(MPUPLL_M_720); 67- mpu_pll_config(MPUPLL_M_720);
49- } else { 68- } else {
50- printf("tps65217_voltage_update failure\n"); 69- printf("tps65217_voltage_update failure\n");
51+ /* Only perform PMIC configurations if board rev > A1 */
52+ if (!strncmp(header.version, "00A1", 4))
53+ return;
54+
55+ if (!(pmic_status_reg & PWR_SRC_AC_BITMASK)) { 70+ if (!(pmic_status_reg & PWR_SRC_AC_BITMASK)) {
56+ printf("No AC power, disabling frequency switch\n"); 71+ printf("No AC power, disabling frequency switch\n");
57+ return; 72+ return;
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index cf1979df..39d88b61 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "(ti33x)" 4COMPATIBLE_MACHINE = "(ti33x)"
5DEFAULT_PREFERENCE_ti33x = "99" 5DEFAULT_PREFERENCE_ti33x = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r18" 7PR = "r19"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"