summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorJoel A Fernandes <joelagnel@ti.com>2011-10-21 09:31:32 -0500
committerKoen Kooi <koen@dominion.thruhere.net>2011-10-21 18:57:36 +0200
commit4e006611b409fa1890d8550857e84f5bbf710047 (patch)
treebe279b7ef90c4bde33cdbde9175f5835dc810d0d /recipes-bsp/u-boot
parentd5ed5042638536846355465bcfab941dcc119782 (diff)
downloadmeta-ti-4e006611b409fa1890d8550857e84f5bbf710047.tar.gz
u-boot 2011.10rc: Read EEPROM header correctly for BeagleBone board detection
This patch fixes the case where the EEPROM is programmed but we still use the fall back case to detect the bone board. Now that EEPROMs are programmed, we should correctly detect the bone board instead of relying on fall back to bone mode. PR bumped Signed-off-by: Joel A Fernandes <joelagnel@ti.com> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch28
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.10rc.bb3
2 files changed, 30 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch b/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch
new file mode 100644
index 00000000..ef901a91
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch
@@ -0,0 +1,28 @@
1From 186250ee6abca3f080b5321504a1c5881ffbf7c6 Mon Sep 17 00:00:00 2001
2From: Joel A Fernandes <joelagnel@ti.com>
3Date: Thu, 20 Oct 2011 19:46:53 -0500
4Subject: [PATCH] am335x-evm: Read name field in EEPROM header for BeagleBoard bone detection
5
6Signed-off-by: Joel A Fernandes <joelagnel@ti.com>
7---
8 board/ti/am335x/evm.c | 4 ++++
9 1 files changed, 4 insertions(+), 0 deletions(-)
10
11diff --git a/board/ti/am335x/evm.c b/board/ti/am335x/evm.c
12index 37e348f..b63dcbe 100755
13--- a/board/ti/am335x/evm.c
14+++ b/board/ti/am335x/evm.c
15@@ -501,6 +501,10 @@ int board_init(void)
16 detect_daughter_board_profile();
17 } else if (!strncmp("SKU#03", header.config, 6)) {
18 board_id = IPP_BOARD;
19+ } else if (!strncmp("A335BONE", header.name, 8)) {
20+ board_id = BONE_BOARD;
21+ profile = 1; /* profile 0 is internally considered as 1 */
22+ daughter_board_connected = 0;
23 } else {
24 printf("Did not find a recognized configuration, "
25 "assuming BeagleBone\n");
26--
271.7.1
28
diff --git a/recipes-bsp/u-boot/u-boot_2011.10rc.bb b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
index 0bd39d37..ca7b670a 100644
--- a/recipes-bsp/u-boot/u-boot_2011.10rc.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.10rc.bb
@@ -4,7 +4,7 @@ require u-boot.inc
4COMPATIBLE_MACHINE = "(ti33x)" 4COMPATIBLE_MACHINE = "(ti33x)"
5DEFAULT_PREFERENCE_ti33x = "99" 5DEFAULT_PREFERENCE_ti33x = "99"
6PV = "2011.09+git" 6PV = "2011.09+git"
7PR = "r14" 7PR = "r15"
8 8
9# SPL build 9# SPL build
10UBOOT_BINARY = "u-boot.img" 10UBOOT_BINARY = "u-boot.img"
@@ -18,6 +18,7 @@ SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;br
18 file://2011.09git/0001-mach-types-Add-new-beaglebone-machine-type.patch \ 18 file://2011.09git/0001-mach-types-Add-new-beaglebone-machine-type.patch \
19 file://2011.09git/0003-am335x_evm-single-byte-address-EEPROM-for-board-iden.patch \ 19 file://2011.09git/0003-am335x_evm-single-byte-address-EEPROM-for-board-iden.patch \
20 file://2011.09git/0004-am335x-evm-fall-back-to-bone-if-header.config-is-emp.patch \ 20 file://2011.09git/0004-am335x-evm-fall-back-to-bone-if-header.config-is-emp.patch \
21 file://2011.09git/0005-am335x-evm-Read-name-field-in-EEPROM-header-for-Beag.patch \
21 " 22 "
22 23
23SRCREV = "9158d7f37d596b867039345cb2e3f8f18f54fe46" 24SRCREV = "9158d7f37d596b867039345cb2e3f8f18f54fe46"