summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-12-09 11:52:46 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-12-24 16:19:25 +0100
commit1f506217992776b7f07983240e497cf6e068fc80 (patch)
tree7f952fc78f099f6da132bb86ac9d0ad0f4d870d8 /recipes-bsp/u-boot
parenta500a970d7e35074adfe36bbc83509015cf33eb2 (diff)
downloadmeta-ti-1f506217992776b7f07983240e497cf6e068fc80.tar.gz
u-boot 2011.12rc1: add beagleboard and pandaboard patches
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch65
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch105
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot_2011.12.bb7
6 files changed, 254 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch b/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch
new file mode 100644
index 00000000..07ab75b1
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch
@@ -0,0 +1,26 @@
1From d0556964b6bd443e8b60d5c0b3326795a02cc8a7 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 27 Nov 2011 14:43:58 +0100
4Subject: [PATCH 1/5] beagleboard: mount rootfs RO instead of RW at boot
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/omap3_beagle.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
12index 91af8a0..d4f33d0 100644
13--- a/include/configs/omap3_beagle.h
14+++ b/include/configs/omap3_beagle.h
15@@ -220,7 +220,7 @@
16 "dvimode=640x480MR-16@60\0" \
17 "defaultdisplay=dvi\0" \
18 "mmcdev=0\0" \
19- "mmcroot=/dev/mmcblk0p2 rw\0" \
20+ "mmcroot=/dev/mmcblk0p2 ro\0" \
21 "mmcrootfstype=ext3 rootwait\0" \
22 "nandroot=ubi0:rootfs ubi.mtd=4\0" \
23 "nandrootfstype=ubifs\0" \
24--
251.7.2.5
26
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch b/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch
new file mode 100644
index 00000000..5af34a15
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch
@@ -0,0 +1,65 @@
1From 28e5cc1f13d817f75638c72eae853e53510a1ab2 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sat, 8 Oct 2011 21:56:35 +0200
4Subject: [PATCH 2/5] beagleboard: add support for TCT Beacon board
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 board/ti/beagle/beagle.c | 10 ++++++++++
9 board/ti/beagle/beagle.h | 7 +++++++
10 2 files changed, 17 insertions(+), 0 deletions(-)
11
12diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
13index 6a457cb..9c2e6d0 100644
14--- a/board/ti/beagle/beagle.c
15+++ b/board/ti/beagle/beagle.c
16@@ -59,11 +59,14 @@ extern volatile struct ehci_hcor *hcor;
17 #define TWL4030_I2C_BUS 0
18 #define EXPANSION_EEPROM_I2C_BUS 1
19 #define EXPANSION_EEPROM_I2C_ADDRESS 0x50
20+#define DVI_EDID_I2C_BUS 2
21+#define DVI_EDID_I2C_ADDRESS 0x50
22
23 #define TINCANTOOLS_ZIPPY 0x01000100
24 #define TINCANTOOLS_ZIPPY2 0x02000100
25 #define TINCANTOOLS_TRAINER 0x04000100
26 #define TINCANTOOLS_SHOWDOG 0x03000100
27+#define TINCANTOOLS_BEACON 0x05000100
28 #define KBADC_BEAGLEFPGA 0x01000600
29 #define LW_BEAGLETOUCH 0x01000700
30 #define BRAINMUX_LCDOG 0x01000800
31@@ -351,6 +354,13 @@ int misc_init_r(void)
32 setenv("defaultdisplay", "showdoglcd");
33 setenv("buddy", "showdog");
34 break;
35+ case TINCANTOOLS_BEACON:
36+ printf("Recognized Tincantools Beacon board (rev %d %s)\n",
37+ expansion_config.revision,
38+ expansion_config.fab_revision);
39+ MUX_TINCANTOOLS_BEACON();
40+ setenv("buddy", "beacon");
41+ break;
42 case KBADC_BEAGLEFPGA:
43 printf("Recognized KBADC Beagle FPGA board\n");
44 MUX_KBADC_BEAGLEFPGA();
45diff --git a/board/ti/beagle/beagle.h b/board/ti/beagle/beagle.h
46index 18bfaa8..6a9ad73 100644
47--- a/board/ti/beagle/beagle.h
48+++ b/board/ti/beagle/beagle.h
49@@ -456,6 +456,13 @@ const omap3_sysinfo sysinfo = {
50 MUX_VAL(CP(MCBSP3_CLKX), (IEN | PTU | EN | M4)) /*GPIO_141*/\
51 MUX_VAL(CP(MCBSP1_CLKX), (IEN | PTU | EN | M4)) /*GPIO_162*/
52
53+#define MUX_TINCANTOOLS_BEACON() \
54+ MUX_VAL(CP(MMC2_DAT3), (IEN | PTU | EN | M4)) /*GPIO_135*/\
55+ MUX_VAL(CP(MMC2_DAT4), (IEN | PTU | EN | M4)) /*GPIO_136*/\
56+ MUX_VAL(CP(MMC2_DAT5), (IEN | PTU | EN | M4)) /*GPIO_137*/\
57+ MUX_VAL(CP(MMC2_DAT6), (IEN | PTU | EN | M4)) /*GPIO_138*/\
58+ MUX_VAL(CP(MMC2_DAT7), (IEN | PTU | EN | M4)) /*GPIO_139*/\
59+
60 #define MUX_KBADC_BEAGLEFPGA() \
61 MUX_VAL(CP(MCBSP1_CLKR), (IEN | PTU | DIS | M1)) /*MCSPI4_CLK*/\
62 MUX_VAL(CP(MCBSP1_DX), (IDIS | PTU | DIS | M1)) /*MCSPI4_SIMO*/\
63--
641.7.2.5
65
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch b/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
new file mode 100644
index 00000000..c8bb1309
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch
@@ -0,0 +1,105 @@
1From 4422038e69f79993cc21e3649715c9556e68413d Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Sun, 27 Nov 2011 14:53:56 +0100
4Subject: [PATCH 3/5] beagleboard: add support for scanning loop-through expansionboards like the uLCD-lite
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 board/ti/beagle/beagle.c | 30 ++++++++++++++++++++++++++----
9 include/configs/omap3_beagle.h | 2 ++
10 2 files changed, 28 insertions(+), 4 deletions(-)
11
12diff --git a/board/ti/beagle/beagle.c b/board/ti/beagle/beagle.c
13index 9c2e6d0..5ea50d1 100644
14--- a/board/ti/beagle/beagle.c
15+++ b/board/ti/beagle/beagle.c
16@@ -74,6 +74,7 @@ extern volatile struct ehci_hcor *hcor;
17 #define BBTOYS_WIFI 0x01000B00
18 #define BBTOYS_VGA 0x02000B00
19 #define BBTOYS_LCD 0x03000B00
20+#define BBTOYS_ULCD 0x04000B00
21 #define BEAGLE_NO_EEPROM 0xffffffff
22
23 DECLARE_GLOBAL_DATA_PTR;
24@@ -209,18 +210,18 @@ void get_board_mem_timings(u32 *mcfg, u32 *ctrla, u32 *ctrlb, u32 *rfr_ctrl,
25 * bus 1 for the availability of an AT24C01B serial EEPROM.
26 * returns the device_vendor field from the EEPROM
27 */
28-unsigned int get_expansion_id(void)
29+unsigned int get_expansion_id(int eeprom_address)
30 {
31 i2c_set_bus_num(EXPANSION_EEPROM_I2C_BUS);
32
33 /* return BEAGLE_NO_EEPROM if eeprom doesn't respond */
34- if (i2c_probe(EXPANSION_EEPROM_I2C_ADDRESS) == 1) {
35+ if (i2c_probe(eeprom_address) == 1) {
36 i2c_set_bus_num(TWL4030_I2C_BUS);
37 return BEAGLE_NO_EEPROM;
38 }
39
40 /* read configuration data */
41- i2c_read(EXPANSION_EEPROM_I2C_ADDRESS, 0, 1, (u8 *)&expansion_config,
42+ i2c_read(eeprom_address, 0, 1, (u8 *)&expansion_config,
43 sizeof(expansion_config));
44
45 i2c_set_bus_num(TWL4030_I2C_BUS);
46@@ -323,7 +324,7 @@ int misc_init_r(void)
47 TWL4030_PM_RECEIVER_DEV_GRP_P1);
48 }
49
50- switch (get_expansion_id()) {
51+ switch (get_expansion_id(EXPANSION_EEPROM_I2C_ADDRESS)) {
52 case TINCANTOOLS_ZIPPY:
53 printf("Recognized Tincantools Zippy board (rev %d %s)\n",
54 expansion_config.revision,
55@@ -402,6 +403,27 @@ int misc_init_r(void)
56 if (expansion_config.content == 1)
57 setenv(expansion_config.env_var, expansion_config.env_setting);
58
59+ /* Scan 0x51 as well for loop-thru boards */
60+ switch (get_expansion_id(EXPANSION_EEPROM_I2C_ADDRESS + 1)) {
61+ case BBTOYS_ULCD:
62+ printf("Recognized BeagleBoardToys uLCD-lite board\n");
63+ setenv("buddy2", "bbtoys-ulcd");
64+ setenv("defaultdisplay", "lcd");
65+ setenv("uenvcmd", "i2c dev 1 ; i2c mw 40 00 00; i2c mw 40 04 80; i2c mw 40 0d 05; i2c mw 40 0d 15");
66+ break;
67+ case BEAGLE_NO_EEPROM:
68+ printf("No EEPROM on expansion board\n");
69+ setenv("buddy2", "none");
70+ break;
71+ default:
72+ printf("Unrecognized expansion board: %x\n",
73+ expansion_config.device_vendor);
74+ setenv("buddy2", "unknown");
75+ }
76+
77+ if (expansion_config.content == 1)
78+ setenv(expansion_config.env_var, expansion_config.env_setting);
79+
80 twl4030_power_init();
81 switch (get_board_revision()) {
82 case REVISION_XM_A:
83diff --git a/include/configs/omap3_beagle.h b/include/configs/omap3_beagle.h
84index d4f33d0..04d3eed 100644
85--- a/include/configs/omap3_beagle.h
86+++ b/include/configs/omap3_beagle.h
87@@ -214,6 +214,7 @@
88 "console=ttyO2,115200n8\0" \
89 "mpurate=auto\0" \
90 "buddy=none "\
91+ "buddy2=none "\
92 "optargs=\0" \
93 "camera=none\0" \
94 "vram=12M\0" \
95@@ -240,6 +241,7 @@
96 "${optargs} " \
97 "mpurate=${mpurate} " \
98 "buddy=${buddy} "\
99+ "buddy2=${buddy2} "\
100 "camera=${camera} "\
101 "vram=${vram} " \
102 "omapfb.mode=dvi:${dvimode} " \
103--
1041.7.2.5
105
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch b/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch
new file mode 100644
index 00000000..0d3655d3
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0004-omap4-common-mount-root-RO.patch
@@ -0,0 +1,26 @@
1From 90dfb660575f15ba736884139f35bfd4ba927468 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 8 Dec 2011 17:22:59 +0100
4Subject: [PATCH 4/5] omap4-common: mount root RO
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/omap4_common.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/omap4_common.h b/include/configs/omap4_common.h
12index a989721..54760e9 100644
13--- a/include/configs/omap4_common.h
14+++ b/include/configs/omap4_common.h
15@@ -154,7 +154,7 @@
16 "usbtty=cdc_acm\0" \
17 "vram=16M\0" \
18 "mmcdev=0\0" \
19- "mmcroot=/dev/mmcblk0p2 rw\0" \
20+ "mmcroot=/dev/mmcblk0p2 ro\0" \
21 "mmcrootfstype=ext3 rootwait\0" \
22 "mmcargs=setenv bootargs console=${console} " \
23 "vram=${vram} " \
24--
251.7.2.5
26
diff --git a/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch b/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch
new file mode 100644
index 00000000..e28eae57
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot/2011.12/0005-omap4-common-use-ext4-by-default.patch
@@ -0,0 +1,26 @@
1From a1f9453f2450762249aa35bd5ae97150acc53eb2 Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Thu, 8 Dec 2011 17:23:24 +0100
4Subject: [PATCH 5/5] omap4-common: use ext4 by default
5
6Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
7---
8 include/configs/omap4_common.h | 2 +-
9 1 files changed, 1 insertions(+), 1 deletions(-)
10
11diff --git a/include/configs/omap4_common.h b/include/configs/omap4_common.h
12index 54760e9..7637688 100644
13--- a/include/configs/omap4_common.h
14+++ b/include/configs/omap4_common.h
15@@ -155,7 +155,7 @@
16 "vram=16M\0" \
17 "mmcdev=0\0" \
18 "mmcroot=/dev/mmcblk0p2 ro\0" \
19- "mmcrootfstype=ext3 rootwait\0" \
20+ "mmcrootfstype=ext4 rootwait\0" \
21 "mmcargs=setenv bootargs console=${console} " \
22 "vram=${vram} " \
23 "root=${mmcroot} " \
24--
251.7.2.5
26
diff --git a/recipes-bsp/u-boot/u-boot_2011.12.bb b/recipes-bsp/u-boot/u-boot_2011.12.bb
index 50a178d2..b735702d 100644
--- a/recipes-bsp/u-boot/u-boot_2011.12.bb
+++ b/recipes-bsp/u-boot/u-boot_2011.12.bb
@@ -6,12 +6,17 @@ UBOOT_IMAGE = "u-boot-${MACHINE}-${PV}-${PR}.img"
6UBOOT_SYMLINK = "u-boot-${MACHINE}.img" 6UBOOT_SYMLINK = "u-boot-${MACHINE}.img"
7 7
8PV = "2011.09+2011.12rc1" 8PV = "2011.09+2011.12rc1"
9PR = "r1"
9 10
10# No patches for other machines yet 11# No patches for other machines yet
11COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)" 12COMPATIBLE_MACHINE = "(beagleboard|pandaboard|hawkboard|am3517-evm|am37x-evm|omap3evm)"
12 13
13SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \ 14SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git \
14 file://fw_env.config \ 15 file://2011.12/0001-beagleboard-mount-rootfs-RO-instead-of-RW-at-boot.patch \
16 file://2011.12/0002-beagleboard-add-support-for-TCT-Beacon-board.patch \
17 file://2011.12/0003-beagleboard-add-support-for-scanning-loop-through-ex.patch \
18 file://2011.12/0004-omap4-common-mount-root-RO.patch \
19 file://2011.12/0005-omap4-common-use-ext4-by-default.patch \
15 " 20 "
16 21
17SRCREV = "d82a27bc5c404da907f71960a3ed2e148ac73fd0" 22SRCREV = "d82a27bc5c404da907f71960a3ed2e148ac73fd0"