diff options
author | Franklin S. Cooper Jr <fcooper@ti.com> | 2013-07-09 14:17:36 -0500 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2013-07-11 13:59:00 -0400 |
commit | 5ff9feb881d43e3f3aea2113c510301b218e9d44 (patch) | |
tree | f3dfd9f99543a7c6b12a5045d5fe544425deaa78 /recipes-bsp/u-boot | |
parent | 383266ca96d2f7f824d2f3c011310164a56fead4 (diff) | |
download | meta-ti-5ff9feb881d43e3f3aea2113c510301b218e9d44.tar.gz |
u-boot: Add memory alignment fix for armv7 for am37x and am3517
* On am335x a memory alignment issue was found when using the Linaro toolchain.
* A similar patch was applied for am335x that fixed this well documented issue.
* Add a similar fix to am37x and am3517 since this is a generic armv7 issue.
Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r-- | recipes-bsp/u-boot/u-boot-am3517_2011.09.bb | 6 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb | 3 | ||||
-rw-r--r-- | recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch | 30 |
3 files changed, 37 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-am3517_2011.09.bb b/recipes-bsp/u-boot/u-boot-am3517_2011.09.bb index 6321406d..06b8cf1a 100644 --- a/recipes-bsp/u-boot/u-boot-am3517_2011.09.bb +++ b/recipes-bsp/u-boot/u-boot-am3517_2011.09.bb | |||
@@ -6,9 +6,11 @@ COMPATIBLE_MACHINE = "omap3" | |||
6 | 6 | ||
7 | DEFAULT_PREFERENCE = "-1" | 7 | DEFAULT_PREFERENCE = "-1" |
8 | 8 | ||
9 | PR = "r0+gitr${SRCPV}" | 9 | PR = "r1+gitr${SRCPV}" |
10 | 10 | ||
11 | SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=${BRANCH}" | 11 | SRC_URI = "git://arago-project.org/git/projects/u-boot-am33x.git;protocol=git;branch=${BRANCH} \ |
12 | file://0001-armv7-Unaligned-access-fix.patch \ | ||
13 | " | ||
12 | 14 | ||
13 | BRANCH = "AM335XPSP_04.06.00.08" | 15 | BRANCH = "AM335XPSP_04.06.00.08" |
14 | 16 | ||
diff --git a/recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb b/recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb index c25cf1e4..1cd96b6a 100644 --- a/recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb +++ b/recipes-bsp/u-boot/u-boot-am37x_2012.04.01.bb | |||
@@ -6,6 +6,8 @@ COMPATIBLE_MACHINE = "am37x-evm|beagleboard" | |||
6 | 6 | ||
7 | BRANCH ?= "master" | 7 | BRANCH ?= "master" |
8 | 8 | ||
9 | PR = "r1+gitr${SRCPV}" | ||
10 | |||
9 | # v2012.04.01 | 11 | # v2012.04.01 |
10 | SRCREV = "415d386877df49eb051b85ef74fa59a16dc17c7d" | 12 | SRCREV = "415d386877df49eb051b85ef74fa59a16dc17c7d" |
11 | 13 | ||
@@ -33,6 +35,7 @@ SRC_URI += "file://0001-omap3_beagle-add-usbethaddr-setting-to-enable-networ.pat | |||
33 | file://0002-omap3evm-Make-the-board-start-at-800MHz.patch \ | 35 | file://0002-omap3evm-Make-the-board-start-at-800MHz.patch \ |
34 | file://0003-beagleboard-Make-xM-rev-C-go-to-800MHz.patch \ | 36 | file://0003-beagleboard-Make-xM-rev-C-go-to-800MHz.patch \ |
35 | file://0001-ARM-omap3-Set-SPL-stack-size-to-8KB-image-to-54KB.patch \ | 37 | file://0001-ARM-omap3-Set-SPL-stack-size-to-8KB-image-to-54KB.patch \ |
38 | file://0001-armv7-Unaligned-access-fix.patch \ | ||
36 | " | 39 | " |
37 | 40 | ||
38 | SPL_BINARY = "MLO" | 41 | SPL_BINARY = "MLO" |
diff --git a/recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch b/recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch new file mode 100644 index 00000000..35307ac0 --- /dev/null +++ b/recipes-bsp/u-boot/u-boot/0001-armv7-Unaligned-access-fix.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From 40f1e7db785f477a2aa145a3b47bd498c48ad52d Mon Sep 17 00:00:00 2001 | ||
2 | From: Steve Kipisz <s-kipisz2@ti.com> | ||
3 | Date: Fri, 14 Jun 2013 05:16:52 -0500 | ||
4 | Subject: [PATCH] armv7:Unaligned access fix | ||
5 | |||
6 | This fixes an unaligned access data abort introduced when using gcc 4.7 | ||
7 | or higher. The Linaro toolchain uses gcc 4.7.3. This is documented in u-boot | ||
8 | doc/README.arm-unaligned-accesses. | ||
9 | |||
10 | Signed-off-by: Steve Kipisz <s-kipisz2@ti.com> | ||
11 | --- | ||
12 | arch/arm/cpu/armv7/config.mk | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/arch/arm/cpu/armv7/config.mk b/arch/arm/cpu/armv7/config.mk | ||
16 | index 9c3e2f3..9736da8 100644 | ||
17 | --- a/arch/arm/cpu/armv7/config.mk | ||
18 | +++ b/arch/arm/cpu/armv7/config.mk | ||
19 | @@ -20,7 +20,7 @@ | ||
20 | # Foundation, Inc., 59 Temple Place, Suite 330, Boston, | ||
21 | # MA 02111-1307 USA | ||
22 | # | ||
23 | -PLATFORM_RELFLAGS += -fno-common -ffixed-r8 -msoft-float | ||
24 | +PLATFORM_RELFLAGS += -fno-common -ffixed-r8 -msoft-float -mno-unaligned-access | ||
25 | |||
26 | # If armv7-a is not supported by GCC fall-back to armv5, which is | ||
27 | # supported by more tool-chains | ||
28 | -- | ||
29 | 1.7.9.5 | ||
30 | |||