summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot.inc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-03-18 17:40:59 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-03-18 19:27:28 -0400
commit32bb599a61429b07c4aeec89c0d764f85a62fe48 (patch)
tree6db9b7278cd4a4987c152bc8bacda71236546dd6 /recipes-bsp/u-boot/u-boot.inc
parentd51042bb73fb429cf3a8ce15c0e80cf0aebd68c5 (diff)
downloadmeta-ti-32bb599a61429b07c4aeec89c0d764f85a62fe48.tar.gz
u-boot.inc: refactor local include file to base off core with TI customizations
* Introduce own namespace to allow multiple instances of the same base version, possibly pulled from different trees or patched/customized for specific SoC. * Suffix-less variant u-boot_YYYY.MM.bb is reserved for mainline versions of the recipe with no or minimal patches, with broader machine selection. * Recipes for machine- or SoC-specific trees should use corresponding suffix - either machine, SoC or the name of the tree. * The .inc file lets the suffixed recipes to provide virtual/bootloader, u-boot, as well as generate conventional u-boot binary packages for direct run-time dependencies. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot.inc')
-rw-r--r--recipes-bsp/u-boot/u-boot.inc68
1 files changed, 0 insertions, 68 deletions
diff --git a/recipes-bsp/u-boot/u-boot.inc b/recipes-bsp/u-boot/u-boot.inc
deleted file mode 100644
index 720f9955..00000000
--- a/recipes-bsp/u-boot/u-boot.inc
+++ /dev/null
@@ -1,68 +0,0 @@
1DESCRIPTION = "U-Boot - the Universal Boot Loader"
2HOMEPAGE = "http://www.denx.de/wiki/U-Boot/WebHome"
3SECTION = "bootloaders"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b"
6
7PROVIDES = "virtual/bootloader"
8
9DEPENDS = "mtd-utils"
10
11PACKAGE_ARCH = "${MACHINE_ARCH}"
12PARALLEL_MAKE=""
13
14EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
15
16UBOOT_MACHINE ?= "${MACHINE}_config"
17UBOOT_BINARY ?= "u-boot.bin"
18UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
19UBOOT_SYMLINK ?= "u-boot-${MACHINE}.bin"
20UBOOT_MAKE_TARGET ?= "all"
21
22do_configure () {
23 oe_runmake ${UBOOT_MACHINE}
24}
25
26do_compile () {
27 unset LDFLAGS
28 unset CFLAGS
29 unset CPPFLAGS
30 oe_runmake ${UBOOT_MAKE_TARGET}
31}
32
33do_install () {
34 install -d ${D}/boot
35 install ${S}/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
36 ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
37
38 if [ -e ${WORKDIR}/fw_env.config ] ; then
39 install -d ${D}${sysconfdir}
40 install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
41 fi
42
43}
44
45FILES_${PN} = "/boot ${sysconfdir}"
46# no gnu_hash in uboot.bin, by design, so skip QA
47INSANE_SKIP_${PN} = "1"
48
49inherit deploy
50
51addtask deploy before do_package after do_compile
52
53do_deploy () {
54 install -d ${DEPLOY_DIR_IMAGE}
55 install ${S}/${UBOOT_BINARY} ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}
56
57 cd ${DEPLOY_DIR_IMAGE}
58 rm -f ${UBOOT_BINARY} ${UBOOT_SYMLINK}
59 ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
60 ln -sf ${UBOOT_IMAGE} ${UBOOT_BINARY}
61
62 if [ -e ${S}/MLO ] ; then
63 install ${S}/MLO ${DEPLOY_DIR_IMAGE}/MLO-${MACHINE}-${PV}
64 rm -f ${DEPLOY_DIR_IMAGE}/MLO-${MACHINE} ${DEPLOY_DIR_IMAGE}/MLO
65 ln -sf MLO-${MACHINE}-${PV} ${DEPLOY_DIR_IMAGE}/MLO-${MACHINE}
66 ln -sf MLO-${MACHINE}-${PV} ${DEPLOY_DIR_IMAGE}/MLO
67 fi
68}