summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-ti.inc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-03-18 17:40:59 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-03-18 19:27:28 -0400
commit32bb599a61429b07c4aeec89c0d764f85a62fe48 (patch)
tree6db9b7278cd4a4987c152bc8bacda71236546dd6 /recipes-bsp/u-boot/u-boot-ti.inc
parentd51042bb73fb429cf3a8ce15c0e80cf0aebd68c5 (diff)
downloadmeta-ti-32bb599a61429b07c4aeec89c0d764f85a62fe48.tar.gz
u-boot.inc: refactor local include file to base off core with TI customizations
* Introduce own namespace to allow multiple instances of the same base version, possibly pulled from different trees or patched/customized for specific SoC. * Suffix-less variant u-boot_YYYY.MM.bb is reserved for mainline versions of the recipe with no or minimal patches, with broader machine selection. * Recipes for machine- or SoC-specific trees should use corresponding suffix - either machine, SoC or the name of the tree. * The .inc file lets the suffixed recipes to provide virtual/bootloader, u-boot, as well as generate conventional u-boot binary packages for direct run-time dependencies. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-ti.inc')
-rw-r--r--recipes-bsp/u-boot/u-boot-ti.inc17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
new file mode 100644
index 00000000..968f3e41
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -0,0 +1,17 @@
1require ${COREBASE}/meta/recipes-bsp/u-boot/u-boot.inc
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/u-boot:"
4
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10PROVIDES += "u-boot"
11PKG_${PN} = "u-boot"
12PKG_${PN}-dev = "u-boot-dev"
13PKG_${PN}-dbg = "u-boot-dbg"
14
15S = "${WORKDIR}/git"
16
17UBOOT_SUFFIX = "img"