summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/trusted-firmware-a
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-05-19 06:32:41 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-05-19 20:30:29 +0000
commit0f99cfb94cc368911e386c248ba3fb2abf9e3fcc (patch)
tree205e7bf5b0778be100dd0dc5815d84711619cb32 /recipes-bsp/trusted-firmware-a
parentf152e696d9466a14e536d4bdece27897bdfacc55 (diff)
downloadmeta-ti-0f99cfb94cc368911e386c248ba3fb2abf9e3fcc.tar.gz
trusted-firmware-a: upstreamed and unified to meta-arm, drop locally
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/trusted-firmware-a')
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
new file mode 100644
index 00000000..d43e7c5a
--- /dev/null
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -0,0 +1,23 @@
1BRANCH_k3 = "ti-atf"
2SRC_URI_k3 = "git://git.ti.com/atf/arm-trusted-firmware.git;branch=${BRANCH}"
3SRCREV_k3 = "5b907a2813faf039d752cdeb6a7b94e95580c46b"
4COMPATIBLE_MACHINE_k3 = "k3"
5TFA_BUILD_TARGET_k3 = "all"
6TFA_INSTALL_TARGET_k3 = "bl31"
7TFA_SPD_k3 = "opteed"
8
9do_compile_append_am65xx-hs-evm() {
10 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
11 ( cd ${B}/${BUILD_DIR}/release/; \
12 mv bl31.bin bl31.bin.unsigned; \
13 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
14 )
15}
16
17do_compile_append_j7-hs-evm() {
18 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
19 ( cd ${B}/${BUILD_DIR}/release/; \
20 mv bl31.bin bl31.bin.unsigned; \
21 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh bl31.bin.unsigned bl31.bin; \
22 )
23}