diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2017-09-19 02:33:33 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-10-02 16:18:37 -0400 |
commit | 97fb053708c2623e161e069cc466152d4e0d1e0c (patch) | |
tree | 92b4321472cb5f90e384728bd1478533ba55e254 /recipes-bsp/transport-rtos | |
parent | 237669570640fda49a9c3a1565437e402275d99d (diff) | |
download | meta-ti-97fb053708c2623e161e069cc466152d4e0d1e0c.tar.gz |
transport-rtos: Added transport recipes(bmet, nimu, nimu-icss) for rtos
RTOS driver for Network Interface Management Unit
(NIMU),BMET Ethernet and NIMU ICSS
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/transport-rtos')
-rw-r--r-- | recipes-bsp/transport-rtos/bmet-eth-rtos_git.bb | 21 | ||||
-rw-r--r-- | recipes-bsp/transport-rtos/nimu-icss-rtos_git.bb | 28 | ||||
-rw-r--r-- | recipes-bsp/transport-rtos/nimu-rtos_git.bb | 33 | ||||
-rw-r--r-- | recipes-bsp/transport-rtos/transport.inc | 17 |
4 files changed, 99 insertions, 0 deletions
diff --git a/recipes-bsp/transport-rtos/bmet-eth-rtos_git.bb b/recipes-bsp/transport-rtos/bmet-eth-rtos_git.bb new file mode 100644 index 00000000..775ef3da --- /dev/null +++ b/recipes-bsp/transport-rtos/bmet-eth-rtos_git.bb | |||
@@ -0,0 +1,21 @@ | |||
1 | SUMMARY = "RTOS driver for BMET Ethernet" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | require transport.inc | ||
5 | |||
6 | PR = "${INC_PR}.0" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://bmet_transport.h;beginline=12;endline=40;md5=7c7fbe6af03d79b61025a67a8fc96f93" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "k2hk-evm|k2e-evm|k2l-evm" | ||
11 | |||
12 | DEPENDS_append = " qmss-lld-rtos \ | ||
13 | cppi-lld-rtos \ | ||
14 | " | ||
15 | |||
16 | BMET_ETH_DESTSUFFIX = "git/bmet_eth" | ||
17 | |||
18 | S = "${WORKDIR}/${BMET_ETH_DESTSUFFIX}" | ||
19 | |||
20 | # HTML doc link params | ||
21 | PDK_COMP_LINK_TEXT = "Baremetal Ethernet Transport" | ||
diff --git a/recipes-bsp/transport-rtos/nimu-icss-rtos_git.bb b/recipes-bsp/transport-rtos/nimu-icss-rtos_git.bb new file mode 100644 index 00000000..3ca196d6 --- /dev/null +++ b/recipes-bsp/transport-rtos/nimu-icss-rtos_git.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | SUMMARY = "RTOS driver for NIMU ICSS" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | require transport.inc | ||
5 | |||
6 | PR = "${INC_PR}.0" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://nimu_icssEth.h;beginline=1;endline=35;md5=fd897e67955a19ba88443d4bc2e7e18a" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g|c66x|omapl1" | ||
11 | |||
12 | DEPENDS_append = " ti-ndk \ | ||
13 | pruss-lld-rtos \ | ||
14 | icss-emac-lld-rtos \ | ||
15 | " | ||
16 | |||
17 | NIMU_ICSS_DESTSUFFIX = "git/ndk/nimu_icss" | ||
18 | |||
19 | # Build with make instead of XDC | ||
20 | TI_PDK_XDCMAKE = "0" | ||
21 | |||
22 | S = "${WORKDIR}/${NIMU_ICSS_DESTSUFFIX}" | ||
23 | |||
24 | export PDK_NIMU_ICSS_ROOT_PATH ="${WORKDIR}/build" | ||
25 | export DEST_ROOT="${S}" | ||
26 | |||
27 | export NDK_INSTALL_PATH = "${NDK_INSTALL_DIR}" | ||
28 | XDCPATH_append = ";${NDK_INSTALL_DIR}/packages" | ||
diff --git a/recipes-bsp/transport-rtos/nimu-rtos_git.bb b/recipes-bsp/transport-rtos/nimu-rtos_git.bb new file mode 100644 index 00000000..5366da7a --- /dev/null +++ b/recipes-bsp/transport-rtos/nimu-rtos_git.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | SUMMARY = "RTOS driver for Network Interface Management Unit (NIMU)" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | require transport.inc | ||
5 | |||
6 | PR = "${INC_PR}.0" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://nimu_eth.h;beginline=1;endline=35;md5=52ba99291b03b91058e37115b66edb10" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|c66x|omapl1" | ||
11 | |||
12 | NIMU_DESTSUFFIX = "git/ndk/nimu" | ||
13 | |||
14 | S = "${WORKDIR}/${NIMU_DESTSUFFIX}" | ||
15 | |||
16 | DEPENDS_append = " ti-ndk osal-rtos" | ||
17 | DEPENDS_append_ti33x = " starterware-rtos emac-lld-rtos" | ||
18 | DEPENDS_append_ti43x = " starterware-rtos emac-lld-rtos" | ||
19 | DEPENDS_append_omap-a15 = " emac-lld-rtos" | ||
20 | DEPENDS_append_keystone = " qmss-lld-rtos cppi-lld-rtos" | ||
21 | DEPENDS_append_k2hk-evm = " pa-lld-rtos" | ||
22 | DEPENDS_append_k2e-evm = " pa-lld-rtos" | ||
23 | DEPENDS_append_k2l-evm = " pa-lld-rtos" | ||
24 | DEPENDS_append_k2g = " emac-lld-rtos" | ||
25 | |||
26 | # Build with make instead of XDC | ||
27 | TI_PDK_XDCMAKE = "0" | ||
28 | |||
29 | export PDK_NIMU_ROOT_PATH ="${WORKDIR}/build" | ||
30 | export DEST_ROOT="${S}" | ||
31 | |||
32 | export NDK_INSTALL_PATH = "${NDK_INSTALL_DIR}" | ||
33 | XDCPATH_append = ";${NDK_INSTALL_DIR}/packages" | ||
diff --git a/recipes-bsp/transport-rtos/transport.inc b/recipes-bsp/transport-rtos/transport.inc new file mode 100644 index 00000000..82427fb9 --- /dev/null +++ b/recipes-bsp/transport-rtos/transport.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | LICENSE = "BSD-3-Clause" | ||
2 | |||
3 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
4 | |||
5 | TRANSPORT_GIT_URI = "git://git.ti.com/keystone-rtos/transport.git" | ||
6 | TRANSPORT_GIT_PROTOCOL = "git" | ||
7 | TRANSPORT_GIT_BRANCH = "master" | ||
8 | |||
9 | # Below commit ID corresponds to "DEV.TRANSPORT.01.00.00.07A" | ||
10 | TRANSPORT_SRCREV = "099dbf371cea3b2d883f5c97a4b0e7ef40e84c6a" | ||
11 | |||
12 | BRANCH = "${TRANSPORT_GIT_BRANCH}" | ||
13 | SRC_URI = "${TRANSPORT_GIT_URI};protocol=${TRANSPORT_GIT_PROTOCOL};branch=${BRANCH}" | ||
14 | |||
15 | SRCREV = "${TRANSPORT_SRCREV}" | ||
16 | PV = "01.00.00.07A" | ||
17 | INC_PR = "r0" | ||