diff options
author | Nishanth Menon <nm@ti.com> | 2021-06-30 12:54:36 -0500 |
---|---|---|
committer | Yogesh Siraswar <yogeshs@ti.com> | 2021-07-07 22:23:13 +0000 |
commit | d5db41417295fe05a293f6d4d77a65ef6563f6ed (patch) | |
tree | b06e8ed5fb515b9685158d33281d84a8b6d10074 /recipes-bsp/ti-sci-fw | |
parent | 69f58002553462703914a9ebb1f83d472ea8294f (diff) | |
download | meta-ti-d5db41417295fe05a293f6d4d77a65ef6563f6ed.tar.gz |
ti-sci-fw: k3-image-gen: Revert SPL address change for mainline
Commit 02a2433c ("ti-sci-fw: Update image gen to latest") switched to a
newer commit in k3-image-gen that also picked up TISCI firmware release,
However, does include a change where the SPL address changed.
This switch in address has been queued for upstream in a future release
(v5.14 + u-boot 2021.10) and current mainline formal tags do not support
this address change. As a result, we have a broken AM64x mainline
support.
Revert this specific change from k3-image-gen for mainline alone for
now.
NOTE: This uses ARAGO_BRAND=mainline which is NOT accurate for meta-ti
which is distro independent, hence without appropriate changes while
using alternate distros, this change will not take effect.
Reported-by: Tom Rini <trini@konsulko.com>
Suggested-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Nishanth Menon <nm@ti.com>
Reviewed-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
Diffstat (limited to 'recipes-bsp/ti-sci-fw')
-rw-r--r-- | recipes-bsp/ti-sci-fw/files/0001-Revert-soc-am64x-Makefile-Move-the-SPL-Load-address-.patch | 36 | ||||
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw.inc | 11 |
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-bsp/ti-sci-fw/files/0001-Revert-soc-am64x-Makefile-Move-the-SPL-Load-address-.patch b/recipes-bsp/ti-sci-fw/files/0001-Revert-soc-am64x-Makefile-Move-the-SPL-Load-address-.patch new file mode 100644 index 00000000..63a5796d --- /dev/null +++ b/recipes-bsp/ti-sci-fw/files/0001-Revert-soc-am64x-Makefile-Move-the-SPL-Load-address-.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From 83d29d5e346083254e71fbe483cb14f6657b9965 Mon Sep 17 00:00:00 2001 | ||
2 | From: Nishanth Menon <nm@ti.com> | ||
3 | Date: Tue, 29 Jun 2021 12:03:29 -0500 | ||
4 | Subject: [PATCH] Revert "soc: am64x: Makefile: Move the SPL Load address to | ||
5 | 0x70000000" | ||
6 | |||
7 | This reverts commit e411dc16862b5bb2d8befb12496b03d7b01c87b2. | ||
8 | |||
9 | Mainline is NOT ready for the change yet as of u-boot 2021.07 + v5.13, | ||
10 | So, this patch reverts the SPL address change. | ||
11 | |||
12 | This patch needs to be dropped once mainline u-boot and kernel have | ||
13 | migrated over to newer releases. | ||
14 | |||
15 | Upstream-Status: Not applicable | ||
16 | Signed-off-by: Nishanth Menon <nm@ti.com> | ||
17 | --- | ||
18 | soc/am64x/Makefile | 2 +- | ||
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
20 | |||
21 | diff --git a/soc/am64x/Makefile b/soc/am64x/Makefile | ||
22 | index 45425428f9c6..e8747376f153 100644 | ||
23 | --- a/soc/am64x/Makefile | ||
24 | +++ b/soc/am64x/Makefile | ||
25 | @@ -30,7 +30,7 @@ | ||
26 | # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. | ||
27 | # | ||
28 | |||
29 | -SBL_LOADADDDR ?= 0x70000000 | ||
30 | +SBL_LOADADDDR ?= 0x70020000 | ||
31 | COMBINED_SYSFW_BRDCFG_LOADADDR ?= 0x70000 | ||
32 | LOADADDR ?= 0x44000 | ||
33 | SCIFS = sci | ||
34 | -- | ||
35 | 2.32.0 | ||
36 | |||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw.inc b/recipes-bsp/ti-sci-fw/ti-sci-fw.inc index 0979ebc6..96604282 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw.inc +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw.inc | |||
@@ -15,4 +15,15 @@ SRC_URI = " \ | |||
15 | git://git.ti.com/k3-image-gen/k3-image-gen.git;protocol=git;branch=master;destsuffix=imggen;name=imggen \ | 15 | git://git.ti.com/k3-image-gen/k3-image-gen.git;protocol=git;branch=master;destsuffix=imggen;name=imggen \ |
16 | " | 16 | " |
17 | 17 | ||
18 | # This is a protection in case the definition is not present in other distros. | ||
19 | ARAGO_BRAND ?= "" | ||
20 | |||
21 | # Mainline u_boot 2021.07 and upstream kernel v5.13 tag cannot use new SPL address | ||
22 | # in K3-Imagegen | ||
23 | SRC_URI += "\ | ||
24 | ${@oe.utils.conditional('ARAGO_BRAND', 'mainline', '\ | ||
25 | file://0001-Revert-soc-am64x-Makefile-Move-the-SPL-Load-address-.patch;patchdir=../imggen \ | ||
26 | ', '', d)} \ | ||
27 | " | ||
28 | |||
18 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |