diff options
author | Andrew Davis <afd@ti.com> | 2022-08-04 21:49:32 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-08-06 19:04:37 -0500 |
commit | 142be8971f67566c8abc137be9ea2f0254b20a90 (patch) | |
tree | 56ee7e83853eb629ae5054490c7f22738900045b /recipes-bsp/ti-sci-fw | |
parent | 50c39940b63713932603ef2bc77d36aaf1f4fb46 (diff) | |
download | meta-ti-142be8971f67566c8abc137be9ea2f0254b20a90.tar.gz |
ti-sci-fw: Make combined R5 boot the default
Going forward, the combined tiboot3.bin is going to be the standard. Only
AM65x and J721e will still use the split boot.
Set DEPENDS and EXTRA_OEMAKE for combined boot and override only for the
two split boot platforms. This makes it easier to add new platforms and
simplifies deployment logic.
Signed-off-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Diffstat (limited to 'recipes-bsp/ti-sci-fw')
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 30 |
1 files changed, 14 insertions, 16 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index 1b2ea184..b06f6abe 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -1,13 +1,12 @@ | |||
1 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | 1 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
2 | 2 | ||
3 | DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" | 3 | DEPENDS = "openssl-native u-boot-mkimage-native dtc-native virtual/bootloader" |
4 | DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader" | 4 | DEPENDS_remove_am65xx-evm-k3r5 = " virtual/bootloader" |
5 | DEPENDS_append_j7200-hs-evm-k3r5 = " virtual/bootloader" | 5 | DEPENDS_remove_am65xx-hs-evm-k3r5 = " virtual/bootloader" |
6 | DEPENDS_append_j721s2-evm-k3r5 = " virtual/bootloader" | 6 | DEPENDS_remove_am65xx-hs-evm-k3r5-sr2 = " virtual/bootloader" |
7 | DEPENDS_append_j721s2-hs-evm-k3r5 = " virtual/bootloader" | 7 | DEPENDS_remove_j7-evm-k3r5 = " virtual/bootloader" |
8 | DEPENDS_append_am64xx-evm-k3r5 = " virtual/bootloader" | 8 | DEPENDS_remove_j7-hs-evm-k3r5 = " virtual/bootloader" |
9 | DEPENDS_append_am64xx-hs-evm-k3r5 = " virtual/bootloader" | 9 | DEPENDS_remove_j7-hs-evm-k3r5-sr1-1 = " virtual/bootloader" |
10 | DEPENDS_append_am62xx-evm-k3r5 = " virtual/bootloader" | ||
11 | 10 | ||
12 | CLEANBROKEN = "1" | 11 | CLEANBROKEN = "1" |
13 | PR = "${INC_PR}.2" | 12 | PR = "${INC_PR}.2" |
@@ -54,15 +53,14 @@ do_configure[noexec] = "1" | |||
54 | EXTRA_OEMAKE = "\ | 53 | EXTRA_OEMAKE = "\ |
55 | CROSS_COMPILE=${TARGET_PREFIX} SOC=${SYSFW_SOC} SOC_TYPE=${SYSFW_SUFFIX} \ | 54 | CROSS_COMPILE=${TARGET_PREFIX} SOC=${SYSFW_SOC} SOC_TYPE=${SYSFW_SUFFIX} \ |
56 | CONFIG=${SYSFW_CONFIG} SYSFW_DIR="${S}/ti-sysfw" \ | 55 | CONFIG=${SYSFW_CONFIG} SYSFW_DIR="${S}/ti-sysfw" \ |
56 | SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin" \ | ||
57 | " | 57 | " |
58 | 58 | EXTRA_OEMAKE_remove_am65xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | |
59 | EXTRA_OEMAKE_append_j7200-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 59 | EXTRA_OEMAKE_remove_am65xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
60 | EXTRA_OEMAKE_append_j7200-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 60 | EXTRA_OEMAKE_remove_am65xx-hs-evm-k3r5-sr2 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
61 | EXTRA_OEMAKE_append_j721s2-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 61 | EXTRA_OEMAKE_remove_j7-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
62 | EXTRA_OEMAKE_append_j721s2-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 62 | EXTRA_OEMAKE_remove_j7-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
63 | EXTRA_OEMAKE_append_am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | 63 | EXTRA_OEMAKE_remove_j7-hs-evm-k3r5-sr1-1 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" |
64 | EXTRA_OEMAKE_append_am64xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | ||
65 | EXTRA_OEMAKE_append_am62xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" | ||
66 | 64 | ||
67 | do_compile() { | 65 | do_compile() { |
68 | cd ${WORKDIR}/imggen/ | 66 | cd ${WORKDIR}/imggen/ |