diff options
author | Denys Dmytriyenko <denys@ti.com> | 2015-12-05 04:15:15 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-12-04 22:10:44 -0500 |
commit | f5c1f1943b24a5a678c0af309692e01722139b06 (patch) | |
tree | 6a8f75b2fbfab8057cc5b569e4ab859dc9158538 /recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |
parent | 8e8618fb00fb63214a2a78c6f878c6e30fc62ded (diff) | |
download | meta-ti-f5c1f1943b24a5a678c0af309692e01722139b06.tar.gz |
ti-sci-fw: rename PMMC firmware to TI SCI and update to the latest
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb')
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb new file mode 100644 index 00000000..4294c6b5 --- /dev/null +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | DESCRIPTION = "TI SCI firmware" | ||
2 | |||
3 | LICENSE = "TI-TFL" | ||
4 | LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c" | ||
5 | |||
6 | PV = "0.1.0.70" | ||
7 | PR = "r0" | ||
8 | |||
9 | CLEANBROKEN = "1" | ||
10 | |||
11 | COMPATIBLE_MACHINE = "k2g-evm" | ||
12 | |||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
14 | |||
15 | SRCREV = "a5b1c3d043fef5869eaa937276976c0e3e23b966" | ||
16 | BRANCH ?= "master" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | TARGET = "ti-sci-firmware-k2g.bin" | ||
22 | |||
23 | do_install() { | ||
24 | install -d ${D}/boot | ||
25 | install -m 0644 ${S}/ti-keystone/${TARGET} ${D}/boot/${TARGET} | ||
26 | } | ||
27 | |||
28 | FILES_${PN} = "/boot" | ||
29 | |||
30 | inherit deploy | ||
31 | |||
32 | do_deploy () { | ||
33 | install -d ${DEPLOYDIR} | ||
34 | install -m 0644 ${S}/ti-keystone/${TARGET} ${DEPLOYDIR}/${TARGET} | ||
35 | } | ||
36 | |||
37 | addtask deploy before do_build after do_compile | ||