summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ti-ocf-crypto-module
diff options
context:
space:
mode:
authorFranklin S. Cooper Jr <fcooper@ti.com>2013-02-11 19:04:41 -0600
committerDenys Dmytriyenko <denys@ti.com>2013-02-12 18:17:26 -0500
commita0c81bbe4f97605edb3e364c2aeea7c04dc776ce (patch)
treee5037ea86db5a2599aebaa4090ba757ab56c019e /recipes-bsp/ti-ocf-crypto-module
parent201b231d721e27ac1d7a88a540b0b2fbbb86ed1e (diff)
downloadmeta-ti-a0c81bbe4f97605edb3e364c2aeea7c04dc776ce.tar.gz
ti-ocf-crypto-module: Port ti-ocf-crypto-module from Arago
* Recipe pulls in ti-ocf-crypto-module from gforge * For am37x, this module allows access to the crypto hardware accelerators through OCF-Linux. Signed-off-by: Franklin S. Cooper Jr <fcooper@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/ti-ocf-crypto-module')
-rw-r--r--recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb b/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
new file mode 100644
index 00000000..ece63d0f
--- /dev/null
+++ b/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "Builds Crypto module used by OCF-Linux driver in OpenSSL example applications"
2HOMEPAGE = "https://gforge.ti.com/gf/project/arm_crypto/"
3LICENSE = "BSD & GPLv2"
4LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=16;md5=acc0590f80e72fd64ad5c16cad8f4f76 \
5 file://ocf_omap3_crypto.c;beginline=436;endline=438;md5=a52cad5c37c3aa3f27c6391552967304"
6
7COMPATIBLE_MACHINE = "am37x-evm|am3517-evm"
8
9DEPENDS += "virtual/kernel"
10
11SRC_URI = "svn://gforge.ti.com/svn/arm_crypto/;module=trunk;protocol=https;user=anonymous;pswd=''"
12
13#gforge source revision
14SRCREV = "17"
15
16INHIBIT_PACKAGE_STRIP = "1"
17
18S = "${WORKDIR}/trunk"
19
20inherit module
21
22MACHINE_KERNEL_PR_append = "a+svnr${SRCPV}"
23PR = "${MACHINE_KERNEL_PR}"
24
25EXTRA_OEMAKE += "KERNEL_DIR=${STAGING_KERNEL_DIR}"
26
27do_compile_prepend () {
28 sed -i "s/arm-none-linux-gnueabi-/${TARGET_PREFIX}/g" ${S}/Makefile
29}
30
31do_install () {
32 install -d ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
33 install -m 0755 ${S}/ocf_omap3_cryptok.ko ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
34}
35
36FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/crypto/ocf/ocf_omap3_cryptok.ko"