summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ti-ocf-crypto-module
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2013-09-09 21:57:18 -0400
committerDenys Dmytriyenko <denys@ti.com>2013-09-10 13:41:31 -0400
commitf3c7afb5a3f762894fb0476081d862cb3d54e2dd (patch)
treec5d4115c2b0285f8f74e1778a36a9fab1f8bcb49 /recipes-bsp/ti-ocf-crypto-module
parentcb6f542fe85ca6d5afa2ff2c49f3af042e95d949 (diff)
downloadmeta-ti-f3c7afb5a3f762894fb0476081d862cb3d54e2dd.tar.gz
ti-ocf-crypto-module: let module.bbclass package modules automatically
The new method is to automatically package modules into kernel-module-<modname> and make the custom name depend on the standard unified one. Messing with FILES_${PN} usually causes problems, so avoid it and let module.bbclass do it's magic. Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/ti-ocf-crypto-module')
-rw-r--r--recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb4
1 files changed, 1 insertions, 3 deletions
diff --git a/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb b/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
index ece63d0f..ad1d5efb 100644
--- a/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
+++ b/recipes-bsp/ti-ocf-crypto-module/ti-ocf-crypto-module_1.0.bb
@@ -19,7 +19,7 @@ S = "${WORKDIR}/trunk"
19 19
20inherit module 20inherit module
21 21
22MACHINE_KERNEL_PR_append = "a+svnr${SRCPV}" 22MACHINE_KERNEL_PR_append = "b+svnr${SRCPV}"
23PR = "${MACHINE_KERNEL_PR}" 23PR = "${MACHINE_KERNEL_PR}"
24 24
25EXTRA_OEMAKE += "KERNEL_DIR=${STAGING_KERNEL_DIR}" 25EXTRA_OEMAKE += "KERNEL_DIR=${STAGING_KERNEL_DIR}"
@@ -32,5 +32,3 @@ do_install () {
32 install -d ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/ 32 install -d ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
33 install -m 0755 ${S}/ocf_omap3_cryptok.ko ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/ 33 install -m 0755 ${S}/ocf_omap3_cryptok.ko ${D}/lib/modules/${KERNEL_VERSION}/crypto/ocf/
34} 34}
35
36FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/crypto/ocf/ocf_omap3_cryptok.ko"