summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
diff options
context:
space:
mode:
authorPraneeth Bajjuri <praneeth@ti.com>2021-11-18 16:40:26 -0600
committerYogesh Siraswar <yogeshs@ti.com>2021-11-18 23:59:51 +0000
commit9e1ba1f2e4b8994cdf0004689b3d1d0c7fb99d2e (patch)
tree0313a1b6fa3635b80e03cdd4e4fa38f27e3c5130 /recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
parent194d0bdc71247f59f0d4713f0f43a216803a75f1 (diff)
downloadmeta-ti-9e1ba1f2e4b8994cdf0004689b3d1d0c7fb99d2e.tar.gz
vxd-dec-fw: Add the recipe for vxd-dec-fw
Add the firmware packaging recipe for the video decoder for j721e. Signed-off-by: Praneeth Bajjuri <praneeth@ti.com> Signed-off-by: Yogesh Siraswar <yogeshs@ti.com> Reviewed-by: Denys Dmytriyenko <denys@konsulko.com>
Diffstat (limited to 'recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb')
-rw-r--r--recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
new file mode 100644
index 00000000..cccda6bb
--- /dev/null
+++ b/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Video Decoding Firmware"
2LICENSE = "TI-IMG"
3LIC_FILES_CHKSUM = "file://LICENSE.ti-img;md5=84ca7278930db001870686ad997d6bb1"
4
5require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
6
7PV = "${IMG_DEC_FW_VERSION}"
8PR = "${INC_PR}.0"
9
10CLEANBROKEN = "1"
11
12COMPATIBLE_MACHINE = "j7"
13
14PACKAGE_ARCH = "${MACHINE_ARCH}"
15
16S = "${WORKDIR}/git"
17TARGET = "pvdec_full_bin.fw"
18
19do_install() {
20 install -d ${D}${base_libdir}/firmware/ti-img
21 install -m 0644 ${S}/ti-img/${TARGET} ${D}${base_libdir}/firmware/ti-img/${TARGET}
22}
23
24FILES_${PN} = "${base_libdir}/firmware"