summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/tcp3d-lld
diff options
context:
space:
mode:
authorMahesh Radhakrishnan <m-radhakrishnan2@ti.com>2017-08-02 21:36:21 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-08-22 16:04:44 -0400
commitab74490bfdf7af221dacd97c3f3d26b14607b6ae (patch)
treece6588398a54c54ac3c0241cf3d83951516a459d /recipes-bsp/tcp3d-lld
parentdc9093f47629592da140854ee451010a9da17f65 (diff)
downloadmeta-ti-ab74490bfdf7af221dacd97c3f3d26b14607b6ae.tar.gz
tcp3d-lld-rtos: Added rtos recipe for tcp3d-lld
Upstreaming RTOS driver for third generation Turbo Coprocessor (TCP3d) Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/tcp3d-lld')
-rw-r--r--recipes-bsp/tcp3d-lld/tcp3d-lld-rtos_git.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes-bsp/tcp3d-lld/tcp3d-lld-rtos_git.bb b/recipes-bsp/tcp3d-lld/tcp3d-lld-rtos_git.bb
new file mode 100644
index 00000000..106071d7
--- /dev/null
+++ b/recipes-bsp/tcp3d-lld/tcp3d-lld-rtos_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "TI third generation Turbo Coprocessor (TCP3) low level driver"
2
3inherit ti-pdk
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://tcp3dver.h;beginline=1;endline=47;md5=3fe46c6320fb9ca4ac6692961402beb7"
7
8COMPATIBLE_MACHINE = "k2hk|k2l-evm|c66x"
9PACKAGE_ARCH = "${MACHINE_ARCH}"
10
11TCP3D_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/tcp3d-lld.git"
12TCP3D_LLD_GIT_PROTOCOL = "git"
13TCP3D_LLD_GIT_BRANCH = "master"
14TCP3D_LLD_GIT_DESTSUFFIX = "git/ti/drv/bcp"
15
16# Below commit ID corresponds to "DEV.TCP3D_LLD.02.01.00.05"
17TCP3D_LLD_SRCREV = "8eb2edfc694982633e0dd01ba7b067ac9f634da9"
18
19BRANCH = "${TCP3D_LLD_GIT_BRANCH}"
20SRC_URI = "${TCP3D_LLD_GIT_URI};destsuffix=${TCP3D_LLD_GIT_DESTSUFFIX};protocol=${TCP3D_LLD_GIT_PROTOCOL};branch=${BRANCH}"
21
22SRCREV = "${TCP3D_LLD_SRCREV}"
23PV = "02.01.00.05"
24PR = "r0"
25
26S = "${WORKDIR}/${TCP3D_LLD_GIT_DESTSUFFIX}"
27
28DEPENDS_append = " edma3-lld-rtos"
29
30export EDMA3LLD_BIOS6_INSTALLDIR = "${EDMA3_LLD_INSTALL_DIR}"
31XDCPATH_append = ";${EDMA3_LLD_INSTALL_DIR}/packages"
32
33# HTML doc link params
34PDK_COMP_LINK_TEXT = "TCP3D LLD"