summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/starterware
diff options
context:
space:
mode:
authorHongmei Gou <a0271529@ti.com>2017-09-01 21:46:43 +0000
committerDenys Dmytriyenko <denys@ti.com>2017-09-05 11:29:58 -0400
commit350ccbc9a81b5765cba1ce45ba87f00b157700f9 (patch)
treee5038bde1e7a26d686954c9849aa891f8a3c1bbe /recipes-bsp/starterware
parent1c924c003fb0cba826ef373bbafe4c81869a9120 (diff)
downloadmeta-ti-350ccbc9a81b5765cba1ce45ba87f00b157700f9.tar.gz
starterware: add starterware for linux which installs header files only
* starterware.inc is created to host the common information Signed-off-by: Hongmei Gou <a0271529@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/starterware')
-rw-r--r--recipes-bsp/starterware/starterware-rtos_git.bb22
-rw-r--r--recipes-bsp/starterware/starterware.inc21
-rw-r--r--recipes-bsp/starterware/starterware_git.bb16
3 files changed, 39 insertions, 20 deletions
diff --git a/recipes-bsp/starterware/starterware-rtos_git.bb b/recipes-bsp/starterware/starterware-rtos_git.bb
index 5584cb2a..88176bb9 100644
--- a/recipes-bsp/starterware/starterware-rtos_git.bb
+++ b/recipes-bsp/starterware/starterware-rtos_git.bb
@@ -1,28 +1,10 @@
1LICENSE = "BSD-3-Clause" 1require starterware.inc
2LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=35;md5=286cbb5dce3e348294b6b025cff969b3"
3 2
4COMPATIBLE_MACHINE = "ti33x|ti43x"
5DEPENDS = "gcc-arm-none-eabi-native" 3DEPENDS = "gcc-arm-none-eabi-native"
6 4
7require recipes-ti/includes/ti-paths.inc 5require recipes-ti/includes/ti-paths.inc
8 6
9PACKAGE_ARCH = "${MACHINE_ARCH}" 7PR = "${INC_PR}.0"
10
11STARTERWARE_GIT_URI = "git://git.ti.com/keystone-rtos/starterware.git"
12STARTERWARE_GIT_PROTOCOL = "git"
13STARTERWARE_GIT_BRANCH = "master"
14
15# Below commit ID corresponds to "DEV.STARTERWARE.PROCSDK.02.01.01.03A"
16STARTERWARE_SRCREV = "08f65ae3d5ccd19fbaf36040a99de971b685d144"
17
18BRANCH = "${STARTERWARE_GIT_BRANCH}"
19SRC_URI = "${STARTERWARE_GIT_URI};protocol=${STARTERWARE_GIT_PROTOCOL};branch=${BRANCH}"
20
21SRCREV = "${STARTERWARE_SRCREV}"
22PV = "02.01.01.03A"
23PR = "r0"
24
25S = "${WORKDIR}/git"
26 8
27PARTNO_ti33x = "am335x" 9PARTNO_ti33x = "am335x"
28PARTNO_ti43x = "am437x" 10PARTNO_ti43x = "am437x"
diff --git a/recipes-bsp/starterware/starterware.inc b/recipes-bsp/starterware/starterware.inc
new file mode 100644
index 00000000..c5d76559
--- /dev/null
+++ b/recipes-bsp/starterware/starterware.inc
@@ -0,0 +1,21 @@
1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://Makefile;beginline=1;endline=35;md5=286cbb5dce3e348294b6b025cff969b3"
3
4COMPATIBLE_MACHINE = "ti33x|ti43x"
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7STARTERWARE_GIT_URI = "git://git.ti.com/keystone-rtos/starterware.git"
8STARTERWARE_GIT_PROTOCOL = "git"
9STARTERWARE_GIT_BRANCH = "master"
10
11# Below commit ID corresponds to "DEV.STARTERWARE.PROCSDK.02.01.01.03A"
12STARTERWARE_SRCREV = "08f65ae3d5ccd19fbaf36040a99de971b685d144"
13
14BRANCH = "${STARTERWARE_GIT_BRANCH}"
15SRC_URI = "${STARTERWARE_GIT_URI};protocol=${STARTERWARE_GIT_PROTOCOL};branch=${BRANCH}"
16
17SRCREV = "${STARTERWARE_SRCREV}"
18PV = "02.01.01.03A"
19INC_PR = "r0"
20
21S = "${WORKDIR}/git"
diff --git a/recipes-bsp/starterware/starterware_git.bb b/recipes-bsp/starterware/starterware_git.bb
new file mode 100644
index 00000000..3adfac36
--- /dev/null
+++ b/recipes-bsp/starterware/starterware_git.bb
@@ -0,0 +1,16 @@
1require starterware.inc
2
3PR = "${INC_PR}.0"
4
5ALLOW_EMPTY_${PN} = "1"
6
7CLEANBROKEN = "1"
8
9do_compile() {
10 :
11}
12
13do_install () {
14 install -d ${D}${includedir}/ti/starterware
15 find . -name "*.h" -type f | xargs -I {} cp --parents --no-preserve=ownership {} ${D}${includedir}/ti/starterware
16}