diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-01-22 11:34:30 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-01-26 13:01:14 -0500 |
commit | ef551169016a3d1d0e6423f6d529d3875003763a (patch) | |
tree | fe0a32de22c8a7606e90632ba99a9d4067e2b0f0 /recipes-bsp/srss-tc | |
parent | c6e1b39389f5a47763482a6284ef530e1004831e (diff) | |
download | meta-ti-ef551169016a3d1d0e6423f6d529d3875003763a.tar.gz |
srss-tc: Add recipe for Smart reflex application
- Provides Smart reflex temperature control with keystone devices
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/srss-tc')
-rw-r--r-- | recipes-bsp/srss-tc/srss-tc_git.bb | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-bsp/srss-tc/srss-tc_git.bb b/recipes-bsp/srss-tc/srss-tc_git.bb new file mode 100644 index 00000000..79edbed6 --- /dev/null +++ b/recipes-bsp/srss-tc/srss-tc_git.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | DESCRIPTION = "TI Smart Reflex temperature control application for KeyStone II" | ||
2 | HOMEPAGE = "http://git.ti.com/cgit/cgit.cgi/keystone-linux/srss-tc.git" | ||
3 | LICENSE = "BSD & MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2c17cd1dc60dc06a4c4f2a2c45472a51" | ||
5 | COMPATIBLE_MACHINE = "keystone" | ||
6 | |||
7 | PV = "1.0.0.0" | ||
8 | |||
9 | BRANCH = "master" | ||
10 | # This commit corresponds to tag DEV.SRSS-TC-01.00.00.00A | ||
11 | SRCREV = "7aaf8308d7ba470144730275df12edae5007e07a" | ||
12 | |||
13 | SRC_URI = "git://git.ti.com/keystone-linux/srss-tc.git;protocol=git;branch=${BRANCH}" | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | SRSS_BIN_NAME = "srss_tc.out" | ||
18 | INITSCRIPT_NAME = "run_srss_tc.sh" | ||
19 | INITSCRIPT_PARAMS = "defaults 10" | ||
20 | |||
21 | inherit update-rc.d | ||
22 | LDFLAGS += "-lrt" | ||
23 | |||
24 | do_install() { | ||
25 | install -d ${D}${bindir}/ | ||
26 | install -c -m 755 ${S}/src/${SRSS_BIN_NAME} ${D}${bindir}/${SRSS_BIN_NAME} | ||
27 | |||
28 | install -d ${D}${sysconfdir}/init.d/ | ||
29 | install -c -m 755 ${S}/scripts/${INITSCRIPT_NAME} ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
30 | } | ||