summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/srio-lld
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2015-02-11 04:56:52 +0000
committerDenys Dmytriyenko <denys@ti.com>2015-02-24 16:09:53 -0500
commit22b8d340af9493c2ab2eece65919dace2e2010aa (patch)
tree54241eeddc947625f4d681b5329e05fa00d16b9b /recipes-bsp/srio-lld
parentb615fa4a504151885220f0a9620b29d7e93bf1bf (diff)
downloadmeta-ti-22b8d340af9493c2ab2eece65919dace2e2010aa.tar.gz
srio-lld: Add recipe for srio peripheral low level driver
- Provides user space low level driver for srio peripheral - Devices supported k2h & k2k Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/srio-lld')
-rw-r--r--recipes-bsp/srio-lld/srio-lld-test_git.bb27
-rw-r--r--recipes-bsp/srio-lld/srio-lld.inc16
-rw-r--r--recipes-bsp/srio-lld/srio-lld_git.bb19
3 files changed, 62 insertions, 0 deletions
diff --git a/recipes-bsp/srio-lld/srio-lld-test_git.bb b/recipes-bsp/srio-lld/srio-lld-test_git.bb
new file mode 100644
index 00000000..7cf254e1
--- /dev/null
+++ b/recipes-bsp/srio-lld/srio-lld-test_git.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "TI SRIO peripheral low level driver unit test and example binaries"
2COMPATIBLE_MACHINE = "keystone"
3DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld srio-lld cmem"
4
5include srio-lld.inc
6
7CHOICELIST = "yes no"
8
9do_compile () {
10# Now build the lld in the updated directory
11 for device in ${DEVICELIST}
12 do
13 oe_runmake clean DEVICE="$device" SRIO_SRC_DIR=${S}
14 for choice in ${CHOICELIST}
15 do
16 oe_runmake tests DEVICE="$device" SRIO_SRC_DIR=${S} USEDYNAMIC_LIB="$choice"
17 oe_runmake examples DEVICE="$device" SRIO_SRC_DIR=${S} USEDYNAMIC_LIB="$choice"
18 done
19 done
20}
21
22do_install () {
23 for device in ${DEVICELIST}
24 do
25 oe_runmake installbin DEVICE="$device" SRIO_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir}
26 done
27}
diff --git a/recipes-bsp/srio-lld/srio-lld.inc b/recipes-bsp/srio-lld/srio-lld.inc
new file mode 100644
index 00000000..1ae21287
--- /dev/null
+++ b/recipes-bsp/srio-lld/srio-lld.inc
@@ -0,0 +1,16 @@
1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/srio/srio_drv.h;beginline=1;endline=41;md5=469096088e072d883ff7eef301b34093"
3
4BRANCH = "master"
5SRC_URI = "git://git.ti.com/keystone-rtos/srio-lld.git;destsuffix=git/ti/drv/srio;protocol=git;branch=${BRANCH}"
6
7# commit ID corresponding to DEV.SRIO_LLD.02.00.00.11
8SRCREV = "2d0efea281222055b3b828c79e57102edaae9db7"
9PV = "02.00.00.11"
10
11DEVICELIST = "k2h k2k"
12
13BASEDIR = "${WORKDIR}/git"
14S = "${BASEDIR}/ti/drv/srio"
15
16EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR}"
diff --git a/recipes-bsp/srio-lld/srio-lld_git.bb b/recipes-bsp/srio-lld/srio-lld_git.bb
new file mode 100644
index 00000000..9ff845b2
--- /dev/null
+++ b/recipes-bsp/srio-lld/srio-lld_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "TI SRIO peripheral low level driver"
2COMPATIBLE_MACHINE = "keystone"
3
4DEPENDS="common-csl-ip rm-lld cppi-lld"
5
6include srio-lld.inc
7
8do_compile () {
9# Now build the lld
10 oe_runmake clean
11 for device in ${DEVICELIST}
12 do
13 oe_runmake lib DEVICE="${device}"
14 done
15}
16
17do_install () {
18 oe_runmake install INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
19}