diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2015-11-04 01:47:30 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-11-04 10:03:29 -0500 |
commit | 5a37604c894f18aa5fde45fd119a9e3e99badd8b (patch) | |
tree | 83e3671819cfc84f7d94af362d69035661bd6b0d /recipes-bsp/srio-lld | |
parent | 2aadb3d5c0263b4a07d77d4cb0efdc7f226fe4ba (diff) | |
download | meta-ti-5a37604c894f18aa5fde45fd119a9e3e99badd8b.tar.gz |
srio-lld: Clean up recipes
* Use INC_PR to track recipe revisions
* Define variables for GIT SRC_URI parameters
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/srio-lld')
-rw-r--r-- | recipes-bsp/srio-lld/srio-lld-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/srio-lld/srio-lld.inc | 14 | ||||
-rw-r--r-- | recipes-bsp/srio-lld/srio-lld_git.bb | 2 |
3 files changed, 15 insertions, 3 deletions
diff --git a/recipes-bsp/srio-lld/srio-lld-test_git.bb b/recipes-bsp/srio-lld/srio-lld-test_git.bb index 7cf254e1..da3e3575 100644 --- a/recipes-bsp/srio-lld/srio-lld-test_git.bb +++ b/recipes-bsp/srio-lld/srio-lld-test_git.bb | |||
@@ -4,6 +4,8 @@ DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld srio-lld cmem" | |||
4 | 4 | ||
5 | include srio-lld.inc | 5 | include srio-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
7 | CHOICELIST = "yes no" | 9 | CHOICELIST = "yes no" |
8 | 10 | ||
9 | do_compile () { | 11 | do_compile () { |
diff --git a/recipes-bsp/srio-lld/srio-lld.inc b/recipes-bsp/srio-lld/srio-lld.inc index 0f1ee2d1..6e51f79c 100644 --- a/recipes-bsp/srio-lld/srio-lld.inc +++ b/recipes-bsp/srio-lld/srio-lld.inc | |||
@@ -1,12 +1,20 @@ | |||
1 | LICENSE = "BSD-3-Clause" | 1 | LICENSE = "BSD-3-Clause" |
2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/srio/srio_drv.h;beginline=1;endline=41;md5=469096088e072d883ff7eef301b34093" | 2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/srio/srio_drv.h;beginline=1;endline=41;md5=469096088e072d883ff7eef301b34093" |
3 | 3 | ||
4 | BRANCH = "master" | 4 | SRIO_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/srio-lld.git" |
5 | SRC_URI = "git://git.ti.com/keystone-rtos/srio-lld.git;destsuffix=git/ti/drv/srio;protocol=git;branch=${BRANCH}" | 5 | SRIO_LLD_GIT_PROTOCOL = "git" |
6 | SRIO_LLD_GIT_BRANCH = "master" | ||
7 | SRIO_LLD_GIT_DESTSUFFIX = "git/ti/drv/srio" | ||
6 | 8 | ||
7 | # commit ID corresponding to DEV.SRIO_LLD.02.00.00.13 | 9 | # commit ID corresponding to DEV.SRIO_LLD.02.00.00.13 |
8 | SRCREV = "dc49972265afd3ffd3b29ca235b8ca6daf790bd1" | 10 | SRIO_LLD_SRCREV = "dc49972265afd3ffd3b29ca235b8ca6daf790bd1" |
11 | |||
12 | BRANCH = "${SRIO_LLD_GIT_BRANCH}" | ||
13 | SRC_URI = "${SRIO_LLD_GIT_URI};destsuffix=${SRIO_LLD_GIT_DESTSUFFIX};protocol=${SRIO_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
14 | SRCREV = "${SRIO_LLD_SRCREV}" | ||
15 | |||
9 | PV = "02.00.00.13" | 16 | PV = "02.00.00.13" |
17 | INC_PR = "r1" | ||
10 | 18 | ||
11 | DEVICELIST = "k2h k2k" | 19 | DEVICELIST = "k2h k2k" |
12 | 20 | ||
diff --git a/recipes-bsp/srio-lld/srio-lld_git.bb b/recipes-bsp/srio-lld/srio-lld_git.bb index 9ff845b2..ba3cc246 100644 --- a/recipes-bsp/srio-lld/srio-lld_git.bb +++ b/recipes-bsp/srio-lld/srio-lld_git.bb | |||
@@ -5,6 +5,8 @@ DEPENDS="common-csl-ip rm-lld cppi-lld" | |||
5 | 5 | ||
6 | include srio-lld.inc | 6 | include srio-lld.inc |
7 | 7 | ||
8 | PR = "${INC_PR}.0" | ||
9 | |||
8 | do_compile () { | 10 | do_compile () { |
9 | # Now build the lld | 11 | # Now build the lld |
10 | oe_runmake clean | 12 | oe_runmake clean |