diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-10-22 10:03:01 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-10-22 12:58:39 -0400 |
commit | 5ae46649cd82a7c05695a089642eeb51f583627a (patch) | |
tree | 92b99072f39e8e29ea42c46d409a372f780bf1c4 /recipes-bsp/sa-lld | |
parent | ff68b5f5f4c1101ce207fe3b6708a61bc461177b (diff) | |
download | meta-ti-5ae46649cd82a7c05695a089642eeb51f583627a.tar.gz |
sa-lld: Update to new version 3.0.0.11
- Add device independent symbolic link for dynamic library
- Add utils to test build
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/sa-lld')
-rw-r--r-- | recipes-bsp/sa-lld/sa-lld-test_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/sa-lld/sa-lld.inc | 7 | ||||
-rw-r--r-- | recipes-bsp/sa-lld/sa-lld_git.bb | 4 |
3 files changed, 8 insertions, 5 deletions
diff --git a/recipes-bsp/sa-lld/sa-lld-test_git.bb b/recipes-bsp/sa-lld/sa-lld-test_git.bb index 2069d415..7cb0ac7a 100644 --- a/recipes-bsp/sa-lld/sa-lld-test_git.bb +++ b/recipes-bsp/sa-lld/sa-lld-test_git.bb | |||
@@ -15,7 +15,7 @@ do_compile () { | |||
15 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} | 15 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} |
16 | for choice in ${CHOICELIST} | 16 | for choice in ${CHOICELIST} |
17 | do | 17 | do |
18 | make -f makefile_armv7 examples PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} USEDYNAMIC_LIB="$choice" | 18 | make -f makefile_armv7 examples utils PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} USEDYNAMIC_LIB="$choice" |
19 | done | 19 | done |
20 | done | 20 | done |
21 | } | 21 | } |
diff --git a/recipes-bsp/sa-lld/sa-lld.inc b/recipes-bsp/sa-lld/sa-lld.inc index 6dc85668..80662796 100644 --- a/recipes-bsp/sa-lld/sa-lld.inc +++ b/recipes-bsp/sa-lld/sa-lld.inc | |||
@@ -5,10 +5,9 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/sa/COPYING.txt;md5=4709d353574a | |||
5 | 5 | ||
6 | BRANCH = "master" | 6 | BRANCH = "master" |
7 | SRC_URI = "git://git.ti.com/keystone-rtos/sa-lld.git;destsuffix=git/ti/drv/sa;protocol=git;branch=${BRANCH}" | 7 | SRC_URI = "git://git.ti.com/keystone-rtos/sa-lld.git;destsuffix=git/ti/drv/sa;protocol=git;branch=${BRANCH}" |
8 | # Following commit DEV.SA_LLD.03.00.00.10 | 8 | # Following commit DEV.SA_LLD.03.00.00.11A |
9 | SRCREV = "533aec7ef0e28c3faff4ee64a861c8935262dc33" | 9 | SRCREV = "bf5b097e868b20d23d386abc34a1902903d7d9ea" |
10 | PV = "03.00.00.10" | 10 | PV = "03.00.00.11" |
11 | PR = "r1" | ||
12 | 11 | ||
13 | BASEDIR = "${WORKDIR}/git" | 12 | BASEDIR = "${WORKDIR}/git" |
14 | S = "${BASEDIR}/ti/drv/sa" | 13 | S = "${BASEDIR}/ti/drv/sa" |
diff --git a/recipes-bsp/sa-lld/sa-lld_git.bb b/recipes-bsp/sa-lld/sa-lld_git.bb index f3458950..3df2c6cb 100644 --- a/recipes-bsp/sa-lld/sa-lld_git.bb +++ b/recipes-bsp/sa-lld/sa-lld_git.bb | |||
@@ -11,4 +11,8 @@ do_compile () { | |||
11 | 11 | ||
12 | do_install () { | 12 | do_install () { |
13 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 13 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}/${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
14 | |||
15 | # Set the generic device library symbolic link | ||
16 | ln -sf libsa.so.1.0.0 ${D}${libdir}/libsa_device.so.1 | ||
17 | ln -sf libsa_device.so.1 ${D}${libdir}/libsa_device.so | ||
14 | } | 18 | } |