summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/sa-lld/sa-lld-test_git.bb
diff options
context:
space:
mode:
authorJacob Stiffler <j-stiffler@ti.com>2018-09-07 19:37:11 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-09-10 18:54:45 +0000
commit7a6f1008255e81fda6292f050409c68edb6c75f8 (patch)
treebc360dc36f3f0757bc5b92ff51c4ea1e042d9312 /recipes-bsp/sa-lld/sa-lld-test_git.bb
parent36b8474560a37de22946891fa043bbc8bfc4662d (diff)
downloadmeta-ti-7a6f1008255e81fda6292f050409c68edb6c75f8.tar.gz
sa-lld: utilize oe_runmake
* This fixes a configure issue when the sources may get cleaned. Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/sa-lld/sa-lld-test_git.bb')
-rw-r--r--recipes-bsp/sa-lld/sa-lld-test_git.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/recipes-bsp/sa-lld/sa-lld-test_git.bb b/recipes-bsp/sa-lld/sa-lld-test_git.bb
index 07d64676..f3fa4f3d 100644
--- a/recipes-bsp/sa-lld/sa-lld-test_git.bb
+++ b/recipes-bsp/sa-lld/sa-lld-test_git.bb
@@ -14,14 +14,17 @@ DEVICELIST_k2e = "k2e"
14 14
15CHOICELIST = "no yes" 15CHOICELIST = "no yes"
16 16
17PARALLEL_MAKE = ""
18EXTRA_OEMAKE = "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} SA_SRC_DIR=${S}"
19
17do_compile () { 20do_compile () {
18# Now build the lld in the updated directory 21# Now build the lld in the updated directory
19 for device in ${DEVICELIST} 22 for device in ${DEVICELIST}
20 do 23 do
21 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} 24 oe_runmake clean DEVICE="$device"
22 for choice in ${CHOICELIST} 25 for choice in ${CHOICELIST}
23 do 26 do
24 make -f makefile_armv7 examples utils PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} USEDYNAMIC_LIB="$choice" 27 oe_runmake examples utils DEVICE="$device" USEDYNAMIC_LIB="$choice"
25 done 28 done
26 done 29 done
27} 30}
@@ -34,7 +37,7 @@ do_install () {
34 37
35 for device in ${DEVICELIST} 38 for device in ${DEVICELIST}
36 do 39 do
37 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" SA_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir} 40 oe_runmake installbin DEVICE="$device" INSTALL_BIN_BASE_DIR=${D}${bindir}
38 done 41 done
39} 42}
40 43