summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rwmem
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-27 00:46:06 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-09-27 06:54:19 +0000
commit43a09d9cc862b6e76bd6fcd89beef2e376fc5318 (patch)
treee86a2eafb40c5375640a06829d61b1d1d8c43154 /recipes-bsp/rwmem
parent5ee68b64a7b31578b585516825aadf098eb17353 (diff)
downloadmeta-ti-43a09d9cc862b6e76bd6fcd89beef2e376fc5318.tar.gz
rwmem: Update to 2.0-rc2+
- New versions uses CMake and extra modules - Correct detection of nm/ranlib/ar for LTO - Fix build with clang/libc++ - depend on python3, needed during build Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/rwmem')
-rw-r--r--recipes-bsp/rwmem/rwmem_1.1.bb13
-rw-r--r--recipes-bsp/rwmem/rwmem_1.2.bb27
2 files changed, 27 insertions, 13 deletions
diff --git a/recipes-bsp/rwmem/rwmem_1.1.bb b/recipes-bsp/rwmem/rwmem_1.1.bb
deleted file mode 100644
index 2848e1cd..00000000
--- a/recipes-bsp/rwmem/rwmem_1.1.bb
+++ /dev/null
@@ -1,13 +0,0 @@
1SUMMARY = "A small tool to read/write memory"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRCREV = "54904b8873b265d8f1faf82617c2f04814c102c6"
6SRC_URI = "git://github.com/tomba/rwmem.git"
7
8S = "${WORKDIR}/git"
9
10do_install() {
11 install -d ${D}${bindir}
12 install -m 0755 rwmem ${D}${bindir}
13}
diff --git a/recipes-bsp/rwmem/rwmem_1.2.bb b/recipes-bsp/rwmem/rwmem_1.2.bb
new file mode 100644
index 00000000..0545b0cc
--- /dev/null
+++ b/recipes-bsp/rwmem/rwmem_1.2.bb
@@ -0,0 +1,27 @@
1SUMMARY = "A small tool to read/write memory"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS += "python3"
6
7PV .= "+git${SRCPV}"
8
9SRCREV_rwmem = "cc296c5366a35a4c4271cfa3cc9831f6f34bfd9d"
10SRCREV_inih = "4b10c654051a86556dfdb634c891b6c3224c4109"
11SRCREV_pybind11 = "9a19306fbf30642ca331d0ec88e7da54a96860f9"
12
13SRCREV_FORMAT = "rwmem_inih_pybind11"
14
15SRC_URI = "git://github.com/tomba/rwmem.git;protocol=https;name=rwmem \
16 git://github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih \
17 git://github.com/pybind/pybind11.git;protocol=https;name=pybind11;nobranch=1;destsuffix=git/ext/pybind11 \
18 "
19
20S = "${WORKDIR}/git"
21
22inherit cmake pkgconfig
23
24do_install() {
25 install -D -m 0755 ${B}/bin/rwmem ${D}${bindir}/rwmem
26 install -D -m 0644 ${B}/lib/librwmem.a ${D}${libdir}/librwmem.a
27}