diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-09-27 00:46:06 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-09-27 06:54:19 +0000 |
commit | 43a09d9cc862b6e76bd6fcd89beef2e376fc5318 (patch) | |
tree | e86a2eafb40c5375640a06829d61b1d1d8c43154 /recipes-bsp/rwmem | |
parent | 5ee68b64a7b31578b585516825aadf098eb17353 (diff) | |
download | meta-ti-43a09d9cc862b6e76bd6fcd89beef2e376fc5318.tar.gz |
rwmem: Update to 2.0-rc2+
- New versions uses CMake and extra modules
- Correct detection of nm/ranlib/ar for LTO
- Fix build with clang/libc++
- depend on python3, needed during build
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/rwmem')
-rw-r--r-- | recipes-bsp/rwmem/rwmem_1.1.bb | 13 | ||||
-rw-r--r-- | recipes-bsp/rwmem/rwmem_1.2.bb | 27 |
2 files changed, 27 insertions, 13 deletions
diff --git a/recipes-bsp/rwmem/rwmem_1.1.bb b/recipes-bsp/rwmem/rwmem_1.1.bb deleted file mode 100644 index 2848e1cd..00000000 --- a/recipes-bsp/rwmem/rwmem_1.1.bb +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | SUMMARY = "A small tool to read/write memory" | ||
2 | LICENSE = "GPLv2+" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
4 | |||
5 | SRCREV = "54904b8873b265d8f1faf82617c2f04814c102c6" | ||
6 | SRC_URI = "git://github.com/tomba/rwmem.git" | ||
7 | |||
8 | S = "${WORKDIR}/git" | ||
9 | |||
10 | do_install() { | ||
11 | install -d ${D}${bindir} | ||
12 | install -m 0755 rwmem ${D}${bindir} | ||
13 | } | ||
diff --git a/recipes-bsp/rwmem/rwmem_1.2.bb b/recipes-bsp/rwmem/rwmem_1.2.bb new file mode 100644 index 00000000..0545b0cc --- /dev/null +++ b/recipes-bsp/rwmem/rwmem_1.2.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | SUMMARY = "A small tool to read/write memory" | ||
2 | LICENSE = "GPLv2+" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
4 | |||
5 | DEPENDS += "python3" | ||
6 | |||
7 | PV .= "+git${SRCPV}" | ||
8 | |||
9 | SRCREV_rwmem = "cc296c5366a35a4c4271cfa3cc9831f6f34bfd9d" | ||
10 | SRCREV_inih = "4b10c654051a86556dfdb634c891b6c3224c4109" | ||
11 | SRCREV_pybind11 = "9a19306fbf30642ca331d0ec88e7da54a96860f9" | ||
12 | |||
13 | SRCREV_FORMAT = "rwmem_inih_pybind11" | ||
14 | |||
15 | SRC_URI = "git://github.com/tomba/rwmem.git;protocol=https;name=rwmem \ | ||
16 | git://github.com/benhoyt/inih.git;protocol=https;name=inih;nobranch=1;destsuffix=git/ext/inih \ | ||
17 | git://github.com/pybind/pybind11.git;protocol=https;name=pybind11;nobranch=1;destsuffix=git/ext/pybind11 \ | ||
18 | " | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | inherit cmake pkgconfig | ||
23 | |||
24 | do_install() { | ||
25 | install -D -m 0755 ${B}/bin/rwmem ${D}${bindir}/rwmem | ||
26 | install -D -m 0644 ${B}/lib/librwmem.a ${D}${libdir}/librwmem.a | ||
27 | } | ||