diff options
author | Sam Nelson <sam.nelson@ti.com> | 2014-10-08 16:27:28 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-10-08 13:27:29 -0400 |
commit | 5171650c1cd2aa7f4d3379657a9cc53899959a47 (patch) | |
tree | 7079dd6b340e4fb877928143b7d3112e6feefcff /recipes-bsp/rm-lld | |
parent | 02d7db614f16d418e6f6a0670c79962193eae911 (diff) | |
download | meta-ti-5171650c1cd2aa7f4d3379657a9cc53899959a47.tar.gz |
ti-rm: Move from meta-arago to meta-ti
- Moved recipe from meta-arago based on review comments
- Provides resource manager low level driver
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/rm-lld')
-rw-r--r-- | recipes-bsp/rm-lld/ti-rm_git.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/recipes-bsp/rm-lld/ti-rm_git.bb b/recipes-bsp/rm-lld/ti-rm_git.bb new file mode 100644 index 00000000..276c01e2 --- /dev/null +++ b/recipes-bsp/rm-lld/ti-rm_git.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | DESCRIPTION = "TI Resource Manager Low Level Driver" | ||
2 | LICENSE = "TI BSD" | ||
3 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/rm/COPYING.txt;md5=dc61631b65360e6beb73b6c337800afc" | ||
4 | |||
5 | BRANCH="master" | ||
6 | SRC_URI = "git://git.ti.com/keystone-rtos/rm-lld.git;destsuffix=git/ti/drv/rm;protocol=git;branch=${BRANCH}" | ||
7 | # Below commit ID corresponds to DEV.RM_LLD.02.01.00.04 | ||
8 | SRCREV = "59e3bf5fca3995dd0f79bbdd1af988d278a2a049" | ||
9 | PR = "r0" | ||
10 | PV = "02.01.00.04" | ||
11 | |||
12 | COMPATIBLE_MACHINE = "keystone" | ||
13 | |||
14 | DEPENDS = "ti-ipc" | ||
15 | |||
16 | PACKAGES =+ "${PN}-test" | ||
17 | |||
18 | FILES_${PN}-test = "${bindir}/rmDspClientTest_*.out \ | ||
19 | ${bindir}/rmLinuxClientTest_*.out \ | ||
20 | ${bindir}/ti/drv/rm/test/dts_files/*.dtb" | ||
21 | |||
22 | DEVICELIST = "k2h k2k" | ||
23 | |||
24 | CHOICELIST = "yes no" | ||
25 | |||
26 | BASEDIR = "${WORKDIR}/git" | ||
27 | S = "${BASEDIR}/ti/drv/rm" | ||
28 | |||
29 | do_compile () { | ||
30 | # Now build the lld | ||
31 | make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} RM_SRC_DIR=${S} | ||
32 | for device in ${DEVICELIST} | ||
33 | do | ||
34 | for choice in ${CHOICELIST} | ||
35 | do | ||
36 | make -f makefile_armv7 tests IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} PDK_INSTALL_PATH=${BASEDIR} DEVICE="$device" USEDYNAMIC_LIB="$choice" | ||
37 | done | ||
38 | done | ||
39 | } | ||
40 | |||
41 | do_install () { | ||
42 | install -d ${D}${includedir}/ti/drv/rm | ||
43 | install -d ${D}${libdir} | ||
44 | install -d ${D}${bindir} | ||
45 | for device in ${DEVICELIST} | ||
46 | do | ||
47 | make -f makefile_armv7 install installbin installbin_test INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device" | ||
48 | done | ||
49 | } | ||