summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/rm-lld/rm-lld_git.bb
diff options
context:
space:
mode:
authorSam Nelson <sam.nelson@ti.com>2014-10-08 16:27:29 +0000
committerDenys Dmytriyenko <denys@ti.com>2014-10-08 13:27:31 -0400
commita9fd89aa06356917f6641fde0903f2d462ab5635 (patch)
tree56c23fd6da411a9fad4a0f4c71078ddaf868fb31 /recipes-bsp/rm-lld/rm-lld_git.bb
parent5171650c1cd2aa7f4d3379657a9cc53899959a47 (diff)
downloadmeta-ti-a9fd89aa06356917f6641fde0903f2d462ab5635.tar.gz
rm-lld: Rename recipe and update to new version
- Removed ti-prefix based on review - Update to new version 2.1.0.6 - Add dependency on libdaemon - Remove device dependency - Updated license to BSD-3-Clause Signed-off-by: Sam Nelson <sam.nelson@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/rm-lld/rm-lld_git.bb')
-rw-r--r--recipes-bsp/rm-lld/rm-lld_git.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-bsp/rm-lld/rm-lld_git.bb b/recipes-bsp/rm-lld/rm-lld_git.bb
new file mode 100644
index 00000000..ed344787
--- /dev/null
+++ b/recipes-bsp/rm-lld/rm-lld_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "TI Resource Manager Low Level Driver"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/rm/COPYING.txt;md5=dc61631b65360e6beb73b6c337800afc"
4
5BRANCH="master"
6SRC_URI = "git://git.ti.com/keystone-rtos/rm-lld.git;destsuffix=git/ti/drv/rm;protocol=git;branch=${BRANCH}"
7# Below commit ID corresponds to DEV.RM_LLD.02.01.00.06
8SRCREV = "dc0dba4a6b0358efcb861d50b3dae21beb5281a8"
9PV = "02.01.00.06"
10PR = "r0"
11
12COMPATIBLE_MACHINE = "keystone"
13
14DEPENDS = "ti-ipc libdaemon"
15
16PACKAGES =+ "${PN}-test"
17
18FILES_${PN}-test = "${bindir}/rmDspClientTest_*.out \
19 ${bindir}/rmLinuxClientTest_*.out \
20 ${bindir}/ti/drv/rm/test/dts_files/*.dtb"
21
22CHOICELIST = "yes no"
23
24BASEDIR = "${WORKDIR}/git"
25S = "${BASEDIR}/ti/drv/rm"
26
27do_compile () {
28# Now build the lld
29 make -f makefile_armv7 clean lib PDK_INSTALL_PATH=${STAGING_INCDIR} RM_SRC_DIR=${S}
30 for choice in ${CHOICELIST}
31 do
32 make -f makefile_armv7 tests IPC_DEVKIT_INSTALL_PATH=${STAGING_INCDIR} PDK_INSTALL_PATH=${BASEDIR} USEDYNAMIC_LIB="$choice"
33 done
34}
35
36do_install () {
37 install -d ${D}${includedir}/ti/drv/rm
38 install -d ${D}${libdir}
39 install -d ${D}${bindir}
40 make -f makefile_armv7 install installbin installbin_test INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} INSTALL_BIN_BASE_DIR=${D}${bindir}
41}