diff options
author | Sam Nelson <sam.nelson@ti.com> | 2015-04-11 03:55:43 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2015-04-10 18:08:45 -0400 |
commit | a2235a7004d4d48ba502de282ee31d571ab4bb70 (patch) | |
tree | 2aa890b713bcaf0192fbf72e8f3643a2cd515d92 /recipes-bsp/qmss-lld | |
parent | ea7cc761702806cc96a60fd492b147cc4c10e852 (diff) | |
download | meta-ti-a2235a7004d4d48ba502de282ee31d571ab4bb70.tar.gz |
qmss-lld: Update to new version 2.1.0.10
- Add init script for creating symbolic link for generic device library at boot time
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/qmss-lld')
-rwxr-xr-x | recipes-bsp/qmss-lld/files/init_qmss.sh | 47 | ||||
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld.inc | 8 | ||||
-rwxr-xr-x | recipes-bsp/qmss-lld/qmss-lld_git.bb | 16 |
3 files changed, 67 insertions, 4 deletions
diff --git a/recipes-bsp/qmss-lld/files/init_qmss.sh b/recipes-bsp/qmss-lld/files/init_qmss.sh new file mode 100755 index 00000000..af695318 --- /dev/null +++ b/recipes-bsp/qmss-lld/files/init_qmss.sh | |||
@@ -0,0 +1,47 @@ | |||
1 | #* | ||
2 | #* Copyright (C) 2015 Texas Instruments Incorporated - http://www.ti.com/ | ||
3 | #* | ||
4 | #* | ||
5 | #* Redistribution and use in source and binary forms, with or without | ||
6 | #* modification, are permitted provided that the following conditions | ||
7 | #* are met: | ||
8 | #* | ||
9 | #* Redistributions of source code must retain the above copyright | ||
10 | #* notice, this list of conditions and the following disclaimer. | ||
11 | #* | ||
12 | #* Redistributions in binary form must reproduce the above copyright | ||
13 | #* notice, this list of conditions and the following disclaimer in the | ||
14 | #* documentation and/or other materials provided with the | ||
15 | #* distribution. | ||
16 | #* | ||
17 | #* Neither the name of Texas Instruments Incorporated nor the names of | ||
18 | #* its contributors may be used to endorse or promote products derived | ||
19 | #* from this software without specific prior written permission. | ||
20 | #* | ||
21 | |||
22 | #! /bin/sh | ||
23 | compatible=$(cat /proc/device-tree/compatible) | ||
24 | |||
25 | cd /usr/lib | ||
26 | case "$compatible" in | ||
27 | *k2hk*) | ||
28 | device=k2hk | ||
29 | ln -sf libqmss_k2h.so.1.0.0 libqmss_device.so.1 | ||
30 | ;; | ||
31 | *k2l*) | ||
32 | device=k2l | ||
33 | ln -sf libqmss_k2l.so.1.0.0 libqmss_device.so.1 | ||
34 | ;; | ||
35 | *k2e*) | ||
36 | device=k2e | ||
37 | ln -sf libqmss_k2e.so.1.0.0 libqmss_device.so.1 | ||
38 | ;; | ||
39 | *) | ||
40 | device=unknown | ||
41 | ;; | ||
42 | esac | ||
43 | |||
44 | if [ $device != unknown ]; then | ||
45 | ln -sf libqmss_device.so.1 libqmss_device.so | ||
46 | echo qmss library link established for device : $device | ||
47 | fi | ||
diff --git a/recipes-bsp/qmss-lld/qmss-lld.inc b/recipes-bsp/qmss-lld/qmss-lld.inc index 87499cc9..d2eb81b0 100644 --- a/recipes-bsp/qmss-lld/qmss-lld.inc +++ b/recipes-bsp/qmss-lld/qmss-lld.inc | |||
@@ -4,10 +4,10 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acd | |||
4 | BRANCH ="master" | 4 | BRANCH ="master" |
5 | SRC_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git;destsuffix=git/ti/drv/qmss;protocol=git;branch=${BRANCH}" | 5 | SRC_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git;destsuffix=git/ti/drv/qmss;protocol=git;branch=${BRANCH}" |
6 | 6 | ||
7 | # commit ID corresponding to DEV.QMSS_LLD.02.01.00.06 | 7 | # commit ID corresponding to DEV.QMSS_LLD.02.01.00.10 |
8 | SRCREV = "661fff76530fd56cf7550f76c7b7a541ea18fda8" | 8 | SRCREV = "ffec14248f460b7cf4def4457f9c2335df62618d" |
9 | PV = "02.01.00.06" | 9 | PV = "02.01.00.10" |
10 | PR = "r0" | 10 | PR = "r1" |
11 | 11 | ||
12 | DEVICELIST = "k2h k2k k2l k2e" | 12 | DEVICELIST = "k2h k2k k2l k2e" |
13 | 13 | ||
diff --git a/recipes-bsp/qmss-lld/qmss-lld_git.bb b/recipes-bsp/qmss-lld/qmss-lld_git.bb index 9d2f547f..38b07621 100755 --- a/recipes-bsp/qmss-lld/qmss-lld_git.bb +++ b/recipes-bsp/qmss-lld/qmss-lld_git.bb | |||
@@ -5,6 +5,14 @@ DEPENDS="common-csl-ip rm-lld" | |||
5 | 5 | ||
6 | include qmss-lld.inc | 6 | include qmss-lld.inc |
7 | 7 | ||
8 | |||
9 | SRC_URI += "file://init_qmss.sh" | ||
10 | |||
11 | inherit update-rc.d | ||
12 | |||
13 | INITSCRIPT_NAME = "init_qmss.sh" | ||
14 | INITSCRIPT_PARAMS = "defaults 10" | ||
15 | |||
8 | do_compile () { | 16 | do_compile () { |
9 | # Now build the lld | 17 | # Now build the lld |
10 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} | 18 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} |
@@ -17,4 +25,12 @@ do_compile () { | |||
17 | 25 | ||
18 | do_install () { | 26 | do_install () { |
19 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | 27 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} |
28 | |||
29 | # Set the generic device library symbolic link to default k2h | ||
30 | cd ${D}${libdir} | ||
31 | ln -sf libqmss_k2h.so.1.0.0 libqmss_device.so.1 | ||
32 | ln -sf libqmss_device.so.1 libqmss_device.so | ||
33 | # Copy init scripts | ||
34 | install -d ${D}${sysconfdir}/init.d/ | ||
35 | install -c -m 755 ${WORKDIR}/init_qmss.sh ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME} | ||
20 | } | 36 | } |