diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2016-01-27 03:16:46 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-01-27 15:54:11 -0500 |
commit | 2eaba56cbf9862d2174bf5339a358a826d6dcd1c (patch) | |
tree | c54ae35839eb961ebe2b6bc5031104357db1b287 /recipes-bsp/qmss-lld | |
parent | 000228e96cea033c4eee9e26c5b22a04f21fccb2 (diff) | |
download | meta-ti-2eaba56cbf9862d2174bf5339a358a826d6dcd1c.tar.gz |
qmss-lld: Upgrade to version 2.1.0.12
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/qmss-lld')
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld-test_git.bb | 4 | ||||
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld.inc | 14 | ||||
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld/qmss-ld-fix-firmware-installation.patch | 13 |
3 files changed, 25 insertions, 6 deletions
diff --git a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb index 60a35b12..5b9ad4ed 100644 --- a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb +++ b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb | |||
@@ -1,10 +1,10 @@ | |||
1 | DESCRIPTION = "TI QMSS low level driver unit test and example binaries" | 1 | DESCRIPTION = "TI QMSS low level driver unit test and example binaries" |
2 | 2 | ||
3 | DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld" | 3 | DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld cmem" |
4 | 4 | ||
5 | include qmss-lld.inc | 5 | include qmss-lld.inc |
6 | 6 | ||
7 | PR = "${INC_PR}.1" | 7 | PR = "${INC_PR}.2" |
8 | 8 | ||
9 | CHOICELIST = "yes no" | 9 | CHOICELIST = "yes no" |
10 | 10 | ||
diff --git a/recipes-bsp/qmss-lld/qmss-lld.inc b/recipes-bsp/qmss-lld/qmss-lld.inc index 9520cea6..fae58e18 100644 --- a/recipes-bsp/qmss-lld/qmss-lld.inc +++ b/recipes-bsp/qmss-lld/qmss-lld.inc | |||
@@ -9,15 +9,15 @@ QMSS_LLD_GIT_PROTOCOL = "git" | |||
9 | QMSS_LLD_GIT_BRANCH = "master" | 9 | QMSS_LLD_GIT_BRANCH = "master" |
10 | QMSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/qmss" | 10 | QMSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/qmss" |
11 | 11 | ||
12 | # commit ID corresponding to DEV.QMSS_LLD.02.01.00.11 | 12 | # commit ID corresponding to DEV.QMSS_LLD.02.01.00.12 |
13 | QMSS_LLD_SRCREV = "2024ab2d411c1a6dd3f5e768a3cb30c2a685f1e4" | 13 | QMSS_LLD_SRCREV = "6b093515f38c6e4d3a8014903a563a9b89fd7c98" |
14 | 14 | ||
15 | BRANCH ="${QMSS_LLD_GIT_BRANCH}" | 15 | BRANCH ="${QMSS_LLD_GIT_BRANCH}" |
16 | SRC_URI = "${QMSS_LLD_GIT_URI};destsuffix=${QMSS_LLD_GIT_DESTSUFFIX};protocol=${QMSS_LLD_GIT_PROTOCOL};branch=${BRANCH}" | 16 | SRC_URI = "${QMSS_LLD_GIT_URI};destsuffix=${QMSS_LLD_GIT_DESTSUFFIX};protocol=${QMSS_LLD_GIT_PROTOCOL};branch=${BRANCH}" |
17 | SRCREV = "${QMSS_LLD_SRCREV}" | 17 | SRCREV = "${QMSS_LLD_SRCREV}" |
18 | 18 | ||
19 | PV = "02.01.00.11" | 19 | PV = "02.01.00.12" |
20 | INC_PR = "r2" | 20 | INC_PR = "r0" |
21 | 21 | ||
22 | DEVICELIST = "k2h k2k k2l k2e" | 22 | DEVICELIST = "k2h k2k k2l k2e" |
23 | DEVICELIST_k2hk-evm = "k2h k2k" | 23 | DEVICELIST_k2hk-evm = "k2h k2k" |
@@ -25,3 +25,9 @@ DEVICELIST_k2l-evm = "k2l" | |||
25 | DEVICELIST_k2e-evm = "k2e" | 25 | DEVICELIST_k2e-evm = "k2e" |
26 | 26 | ||
27 | S = "${WORKDIR}/${QMSS_LLD_GIT_DESTSUFFIX}" | 27 | S = "${WORKDIR}/${QMSS_LLD_GIT_DESTSUFFIX}" |
28 | |||
29 | FILESEXTRAPATHS_prepend := "${THISDIR}/qmss-lld:" | ||
30 | |||
31 | SRC_URI_append = " \ | ||
32 | file://qmss-ld-fix-firmware-installation.patch \ | ||
33 | " | ||
diff --git a/recipes-bsp/qmss-lld/qmss-lld/qmss-ld-fix-firmware-installation.patch b/recipes-bsp/qmss-lld/qmss-lld/qmss-ld-fix-firmware-installation.patch new file mode 100644 index 00000000..a48aae19 --- /dev/null +++ b/recipes-bsp/qmss-lld/qmss-lld/qmss-ld-fix-firmware-installation.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | diff --git a/makefile_armv7 b/makefile_armv7 | ||
2 | index a1fd5c0..d050ace 100644 | ||
3 | --- a/makefile_armv7 | ||
4 | +++ b/makefile_armv7 | ||
5 | @@ -117,7 +117,7 @@ install: | ||
6 | install -d $(INSTALL_LIB_BASE_DIR) | ||
7 | $(CP) ./*.h $(INSTALL_INC_BASE_DIR)/ti/drv/qmss | ||
8 | $(CP) ./include/*.h $(INSTALL_INC_BASE_DIR)/ti/drv/qmss/include | ||
9 | - $(CP) ./firmware/*.h $(INSTALL_INC_BASE_DIR)/ti/drv/qmss/firmware | ||
10 | + $(CP) -r ./firmware/* $(INSTALL_INC_BASE_DIR)/ti/drv/qmss/firmware | ||
11 | $(CP) -r ./device $(INSTALL_INC_BASE_DIR)/ti/drv/qmss/ | ||
12 | @$(CP) -r $(ARMV7LIBDIR)/*.a $(INSTALL_LIB_BASE_DIR) | ||
13 | @$(CP) -r $(ARMV7LIBDIR)/*.so $(INSTALL_LIB_BASE_DIR) | ||