diff options
author | Sam Nelson <sam.nelson@ti.com> | 2014-12-17 00:12:11 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2014-12-18 12:43:30 -0500 |
commit | d0a7ce516faddbff49f6e7065d7c6ea6c0165c3f (patch) | |
tree | 92746e46d2c0bcc2e787aa18cca9e0830724deee /recipes-bsp/qmss-lld | |
parent | 70664faa8da48c0c8cfed96c89c038017b8bfea1 (diff) | |
download | meta-ti-d0a7ce516faddbff49f6e7065d7c6ea6c0165c3f.tar.gz |
qmss-lld: Add new recipe for QMSS Module low level driver
- Provides low level driver and test code for Queue managment subsystem module
- Supports k2h, k2k, k2l k2e devices
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/qmss-lld')
-rwxr-xr-x | recipes-bsp/qmss-lld/qmss-lld-test_git.bb | 27 | ||||
-rw-r--r-- | recipes-bsp/qmss-lld/qmss-lld.inc | 15 | ||||
-rwxr-xr-x | recipes-bsp/qmss-lld/qmss-lld_git.bb | 20 |
3 files changed, 62 insertions, 0 deletions
diff --git a/recipes-bsp/qmss-lld/qmss-lld-test_git.bb b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb new file mode 100755 index 00000000..438d8402 --- /dev/null +++ b/recipes-bsp/qmss-lld/qmss-lld-test_git.bb | |||
@@ -0,0 +1,27 @@ | |||
1 | DESCRIPTION = "TI QMSS low level driver unit test and example binaries" | ||
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | |||
4 | DEPENDS="common-csl-ip rm-lld cppi-lld qmss-lld" | ||
5 | |||
6 | include qmss-lld.inc | ||
7 | |||
8 | CHOICELIST = "yes no" | ||
9 | |||
10 | do_compile () { | ||
11 | # Now build the lld in the updated directory | ||
12 | for device in ${DEVICELIST} | ||
13 | do | ||
14 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" QMSS_SRC_DIR=${S} | ||
15 | for choice in ${CHOICELIST} | ||
16 | do | ||
17 | make -f makefile_armv7 tests examples PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" QMSS_SRC_DIR=${S} USEDYNAMIC_LIB="$choice" | ||
18 | done | ||
19 | done | ||
20 | } | ||
21 | |||
22 | do_install () { | ||
23 | for device in ${DEVICELIST} | ||
24 | do | ||
25 | make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="$device" QMSS_SRC_DIR=${S} INSTALL_BIN_BASE_DIR=${D}${bindir} | ||
26 | done | ||
27 | } | ||
diff --git a/recipes-bsp/qmss-lld/qmss-lld.inc b/recipes-bsp/qmss-lld/qmss-lld.inc new file mode 100644 index 00000000..87499cc9 --- /dev/null +++ b/recipes-bsp/qmss-lld/qmss-lld.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | LICENSE = "BSD-3-Clause" | ||
2 | LIC_FILES_CHKSUM = "file://${WORKDIR}/git/ti/drv/qmss/COPYING.txt;md5=e8f6789acdcda76d02ed9203fc2e603d" | ||
3 | |||
4 | BRANCH ="master" | ||
5 | SRC_URI = "git://git.ti.com/keystone-rtos/qmss-lld.git;destsuffix=git/ti/drv/qmss;protocol=git;branch=${BRANCH}" | ||
6 | |||
7 | # commit ID corresponding to DEV.QMSS_LLD.02.01.00.06 | ||
8 | SRCREV = "661fff76530fd56cf7550f76c7b7a541ea18fda8" | ||
9 | PV = "02.01.00.06" | ||
10 | PR = "r0" | ||
11 | |||
12 | DEVICELIST = "k2h k2k k2l k2e" | ||
13 | |||
14 | BASEDIR = "${WORKDIR}/git" | ||
15 | S = "${BASEDIR}/ti/drv/qmss" | ||
diff --git a/recipes-bsp/qmss-lld/qmss-lld_git.bb b/recipes-bsp/qmss-lld/qmss-lld_git.bb new file mode 100755 index 00000000..9d2f547f --- /dev/null +++ b/recipes-bsp/qmss-lld/qmss-lld_git.bb | |||
@@ -0,0 +1,20 @@ | |||
1 | DESCRIPTION = "TI QMSS low level driver library" | ||
2 | COMPATIBLE_MACHINE = "keystone" | ||
3 | |||
4 | DEPENDS="common-csl-ip rm-lld" | ||
5 | |||
6 | include qmss-lld.inc | ||
7 | |||
8 | do_compile () { | ||
9 | # Now build the lld | ||
10 | make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR} | ||
11 | for device in ${DEVICELIST} | ||
12 | do | ||
13 | make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR} DEVICE="${device}" | ||
14 | done | ||
15 | |||
16 | } | ||
17 | |||
18 | do_install () { | ||
19 | make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir} | ||
20 | } | ||