summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pruss-lld
diff options
context:
space:
mode:
authorJustin Sobota <jsobota@ti.com>2016-12-15 21:54:40 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-12-19 18:14:11 -0500
commitb591b605e0b7275b2514155f060b8c3af6d47e5b (patch)
treed6d47fb965f4e5f144169197afab9c5dbd869f6c /recipes-bsp/pruss-lld
parente5be57d13d7cbb42e95d360f3153ae796864ad8d (diff)
downloadmeta-ti-b591b605e0b7275b2514155f060b8c3af6d47e5b.tar.gz
pruss-lld: Upstream version 1.0.0.5A
Signed-off-by: Justin Sobota <jsobota@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pruss-lld')
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-test_git.bb19
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld.inc20
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld_git.bb20
3 files changed, 59 insertions, 0 deletions
diff --git a/recipes-bsp/pruss-lld/pruss-lld-test_git.bb b/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
new file mode 100644
index 00000000..d994ec8f
--- /dev/null
+++ b/recipes-bsp/pruss-lld/pruss-lld-test_git.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "TI PRUSS low level driver tests"
2
3DEPENDS="common-csl-ip pruss-lld osal"
4
5include pruss-lld.inc
6
7PR = "${INC_PR}.0"
8
9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
10
11do_compile () {
12# Build the tests
13 make -f makefile_armv7 tests PDK_INSTALL_PATH=${STAGING_INCDIR} PRUSS_SRC_DIR=${S}
14}
15
16do_install () {
17# Install the binary
18 make -f makefile_armv7 installbin PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_BIN_BASE_DIR=${D}${bindir} PRUSS_SRC_DIR=${S}
19}
diff --git a/recipes-bsp/pruss-lld/pruss-lld.inc b/recipes-bsp/pruss-lld/pruss-lld.inc
new file mode 100644
index 00000000..52a92bdd
--- /dev/null
+++ b/recipes-bsp/pruss-lld/pruss-lld.inc
@@ -0,0 +1,20 @@
1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://pruicss.h;beginline=1;endline=31;md5=315177aa03d58bcd124a6e799e2bd458"
3
4COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k2g-evm"
5PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7PRUSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pruss-lld.git"
8PRUSS_LLD_GIT_PROTOCOL = "git"
9PRUSS_LLD_GIT_BRANCH = "master"
10PRUSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/pruss"
11
12# Below commit ID corresponds to "DEV.PRUSS_LLD.01.00.00.05A"
13PRUSS_LLD_SRCREV = "7421ea14f163fb3c95c3645fe0add1e05da9d748"
14
15BRANCH = "${PRUSS_LLD_GIT_BRANCH}"
16SRC_URI = "${PRUSS_LLD_GIT_URI};destsuffix=${PRUSS_LLD_GIT_DESTSUFFIX};protocol=${PRUSS_LLD_GIT_PROTOCOL};branch=${BRANCH}"
17
18SRCREV = "${PRUSS_LLD_SRCREV}"
19PV = "01.00.00.05A"
20INC_PR = "r0"
diff --git a/recipes-bsp/pruss-lld/pruss-lld_git.bb b/recipes-bsp/pruss-lld/pruss-lld_git.bb
new file mode 100644
index 00000000..72670f44
--- /dev/null
+++ b/recipes-bsp/pruss-lld/pruss-lld_git.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "TI PRUSS low level driver library"
2
3DEPENDS="common-csl-ip osal"
4
5include pruss-lld.inc
6
7PR = "${INC_PR}.1"
8
9S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
10
11do_compile () {
12# Build the lib
13 make -f makefile_armv7 clean PDK_INSTALL_PATH=${STAGING_INCDIR}
14 make -f makefile_armv7 lib PDK_INSTALL_PATH=${STAGING_INCDIR}
15}
16
17do_install () {
18# Install the lib
19 make -f makefile_armv7 install PDK_INSTALL_PATH=${STAGING_INCDIR} INSTALL_INC_BASE_DIR=${D}${includedir} INSTALL_LIB_BASE_DIR=${D}${libdir}
20}