summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pruss-lld
diff options
context:
space:
mode:
authorHongmei Gou <a0271529@ti.com>2018-07-20 01:11:38 +0000
committerDenys Dmytriyenko <denys@ti.com>2018-07-24 18:18:49 +0000
commit6a72fa2dda9987dbadf1c656d246097506c061b9 (patch)
treec2b2f6f6f039ac7bb9a618796e1e185f842f109e /recipes-bsp/pruss-lld
parented31b5866a773aab6587de8096dfd5960d5e018a (diff)
downloadmeta-ti-6a72fa2dda9987dbadf1c656d246097506c061b9.tar.gz
pruss-lld-apps: build example applications of pruss-lld
* The current example application is Simple Open Real-Time Ethernet (SORTE). It is ported to Linux user space utilizing UIO. Signed-off-by: Hongmei Gou <a0271529@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pruss-lld')
-rw-r--r--recipes-bsp/pruss-lld/pruss-lld-apps_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb b/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb
new file mode 100644
index 00000000..5867984b
--- /dev/null
+++ b/recipes-bsp/pruss-lld/pruss-lld-apps_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "TI PRUSS low level driver example applications"
2
3DEPENDS="common-csl-ip pruss-lld osal ti-pdk-build-rtos pruss-lld-rtos"
4
5DEPENDS_append_ti33x = " starterware"
6DEPENDS_append_ti43x = " starterware"
7
8include pruss-lld.inc
9
10PR = "${INC_PR}.0"
11
12S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}"
13
14EXTRA_OEMAKE += "-f makefile_armv7 PDK_INSTALL_PATH=${STAGING_INCDIR} PDK_PKG_PATH=${STAGING_DATADIR}/ti/ti-pdk-tree/packages PRUSS_SRC_DIR=${S}"
15
16
17DEVICE_LIST ?= "${TI_PDK_LIMIT_SOCS}"
18
19do_compile () {
20# Build the apps
21 for device in ${DEVICE_LIST}
22 do
23 oe_runmake apps DEVICE="$device"
24 done
25}
26
27do_install () {
28# Install the app binary
29 for device in ${DEVICE_LIST}
30 do
31 oe_runmake installapp INSTALL_BIN_BASE_DIR=${D}${bindir} DEVICE="$device"
32 done
33}