diff options
author | Mahesh Radhakrishnan <m-radhakrishnan2@ti.com> | 2017-09-19 02:22:39 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-09-28 13:24:43 -0400 |
commit | 511b167f6683b76ea8f3853e3b8ea0199b0fa25d (patch) | |
tree | f4db35a211e9bfb76ca0dc9591ecc6aa27c214f5 /recipes-bsp/pruss-lld | |
parent | 7d038d894ad6584d81063fef6b246289d3565a98 (diff) | |
download | meta-ti-511b167f6683b76ea8f3853e3b8ea0199b0fa25d.tar.gz |
pruss-lld: Add rtos recipe & update the version to 1.0.0.7
RTOS low level driver for the PRUSS module
Signed-off-by: Mahesh Radhakrishnan <m-radhakrishnan2@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pruss-lld')
-rw-r--r-- | recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb | 23 | ||||
-rw-r--r-- | recipes-bsp/pruss-lld/pruss-lld.inc | 8 |
2 files changed, 27 insertions, 4 deletions
diff --git a/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb b/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb new file mode 100644 index 00000000..50682867 --- /dev/null +++ b/recipes-bsp/pruss-lld/pruss-lld-rtos_git.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | SUMMARY = "TI RTOS low level driver library for PRUSS" | ||
2 | |||
3 | inherit ti-pdk | ||
4 | require recipes-bsp/pruss-lld/pruss-lld.inc | ||
5 | |||
6 | PR = "${INC_PR}.0" | ||
7 | |||
8 | S = "${WORKDIR}/${PRUSS_LLD_GIT_DESTSUFFIX}" | ||
9 | |||
10 | DEPENDS_append = " osal-rtos" | ||
11 | DEPENDS_append_ti33x = " starterware-rtos" | ||
12 | DEPENDS_append_ti43x = " starterware-rtos" | ||
13 | |||
14 | # Build with make instead of XDC | ||
15 | TI_PDK_XDCMAKE = "0" | ||
16 | |||
17 | export PDK_PRUSS_ROOT_PATH ="${WORKDIR}/build" | ||
18 | export DEST_ROOT="${WORKDIR}/build" | ||
19 | |||
20 | # HTML doc link params | ||
21 | PDK_COMP_LINK_TEXT = "PRUSS LLD" | ||
22 | |||
23 | INSANE_SKIP_${PN} = "arch" | ||
diff --git a/recipes-bsp/pruss-lld/pruss-lld.inc b/recipes-bsp/pruss-lld/pruss-lld.inc index 86201080..44d84b83 100644 --- a/recipes-bsp/pruss-lld/pruss-lld.inc +++ b/recipes-bsp/pruss-lld/pruss-lld.inc | |||
@@ -1,7 +1,7 @@ | |||
1 | LICENSE = "BSD-3-Clause" | 1 | LICENSE = "BSD-3-Clause" |
2 | LIC_FILES_CHKSUM = "file://pruicss.h;beginline=1;endline=31;md5=315177aa03d58bcd124a6e799e2bd458" | 2 | LIC_FILES_CHKSUM = "file://pruicss.h;beginline=1;endline=31;md5=315177aa03d58bcd124a6e799e2bd458" |
3 | 3 | ||
4 | COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|k2g-evm" | 4 | COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|k2g" |
5 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 5 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
6 | 6 | ||
7 | PRUSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pruss-lld.git" | 7 | PRUSS_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/pruss-lld.git" |
@@ -9,12 +9,12 @@ PRUSS_LLD_GIT_PROTOCOL = "git" | |||
9 | PRUSS_LLD_GIT_BRANCH = "master" | 9 | PRUSS_LLD_GIT_BRANCH = "master" |
10 | PRUSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/pruss" | 10 | PRUSS_LLD_GIT_DESTSUFFIX = "git/ti/drv/pruss" |
11 | 11 | ||
12 | # Below commit ID corresponds to "DEV.PRUSS_LLD.01.00.00.06A" | 12 | # Below commit ID corresponds to "DEV.PRUSS_LLD.01.00.00.07" |
13 | PRUSS_LLD_SRCREV = "b98729cc1fc26c9ac32846146892646a23c28adb" | 13 | PRUSS_LLD_SRCREV = "636bb5645014723c54c08245cf8c2ee401eceb4f" |
14 | 14 | ||
15 | BRANCH = "${PRUSS_LLD_GIT_BRANCH}" | 15 | BRANCH = "${PRUSS_LLD_GIT_BRANCH}" |
16 | SRC_URI = "${PRUSS_LLD_GIT_URI};destsuffix=${PRUSS_LLD_GIT_DESTSUFFIX};protocol=${PRUSS_LLD_GIT_PROTOCOL};branch=${BRANCH}" | 16 | SRC_URI = "${PRUSS_LLD_GIT_URI};destsuffix=${PRUSS_LLD_GIT_DESTSUFFIX};protocol=${PRUSS_LLD_GIT_PROTOCOL};branch=${BRANCH}" |
17 | 17 | ||
18 | SRCREV = "${PRUSS_LLD_SRCREV}" | 18 | SRCREV = "${PRUSS_LLD_SRCREV}" |
19 | PV = "01.00.00.06A" | 19 | PV = "01.00.00.07" |
20 | INC_PR = "r0" | 20 | INC_PR = "r0" |