summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/pruhsr-fw
diff options
context:
space:
mode:
authorMurali Karicheri <m-karicheri2@ti.com>2020-07-07 23:33:59 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-07-07 18:31:01 +0000
commit0d959d68aa883f70684cfcbd5fe3b9e33d0c27f3 (patch)
treeff24773fa2a3c654d893d27308d6548df29cd76f /recipes-bsp/pruhsr-fw
parentf2b2b2095f1a9d3ef705f7518d9db1e3141da2fb (diff)
downloadmeta-ti-0d959d68aa883f70684cfcbd5fe3b9e33d0c27f3.tar.gz
prueth-hsr/prp: add hsr/prp firmware recipe for version 2.15.23
This patch adds recipe for hsr/prp firmware on am3/4/5 SoCs. The binary files are located on ti-linux-firmware.git. This is a forward port of the recipe from processor sdk 6.3 Signed-off-by: Jacob Stiffler <j-stiffler@ti.com> Signed-off-by: Murali Karicheri <m-karicheri2@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/pruhsr-fw')
-rw-r--r--recipes-bsp/pruhsr-fw/pruhsr-fw_git.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/recipes-bsp/pruhsr-fw/pruhsr-fw_git.bb b/recipes-bsp/pruhsr-fw/pruhsr-fw_git.bb
new file mode 100644
index 00000000..0c7e7148
--- /dev/null
+++ b/recipes-bsp/pruhsr-fw/pruhsr-fw_git.bb
@@ -0,0 +1,36 @@
1SUMMARY = "PRU HSR firmware for AM335x/AM437x/AM57xx"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PV = "2.15.23"
7PE = "1"
8PR = "r0"
9
10COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14SRCREV = "313e20f312a286bc07b97ef9aca70ef3ce96af29"
15BRANCH ?= "ti-linux-firmware"
16
17SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
18
19S = "${WORKDIR}/git"
20
21TARGET = ""
22TARGET_ti33x = "am335x-pru0-pruhsr-fw.elf am335x-pru1-pruhsr-fw.elf"
23TARGET_ti43x = "am437x-pru0-pruhsr-fw.elf am437x-pru1-pruhsr-fw.elf"
24TARGET_am57xx-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
25TARGET_am57xx-hs-evm = "am57xx-pru0-pruhsr-fw.elf am57xx-pru1-pruhsr-fw.elf"
26
27do_install() {
28 install -d ${D}${base_libdir}/firmware/ti-pruss
29 for f in ${TARGET}; do
30 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
31 done
32}
33
34FILES_${PN} = "${base_libdir}/firmware"
35
36INSANE_SKIP_${PN} = "arch"