summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/prueth-fw
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-02-23 04:25:32 +0000
committerDenys Dmytriyenko <denys@ti.com>2016-02-23 16:26:53 -0500
commitc0e9d9f4ca3e3dc78c4bbfd9720dc37342ef3307 (patch)
tree3415e85bec8417ef7d861bb008ec2bb987b6b6ba /recipes-bsp/prueth-fw
parentd3e3d05baab04a19a1b3f5718a47b3098c55e428 (diff)
downloadmeta-ti-c0e9d9f4ca3e3dc78c4bbfd9720dc37342ef3307.tar.gz
prueth-fw: add firmware images for PRU Ethernet on AM57xx
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/prueth-fw')
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw_git.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw_git.bb b/recipes-bsp/prueth-fw/prueth-fw_git.bb
new file mode 100644
index 00000000..3b760ac7
--- /dev/null
+++ b/recipes-bsp/prueth-fw/prueth-fw_git.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "PRU Ethernet firmware for AM57xx"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PV = "1.0.0"
7PR = "r0"
8
9CLEANBROKEN = "1"
10
11COMPATIBLE_MACHINE = "am57xx-evm"
12
13PACKAGE_ARCH = "${MACHINE_ARCH}"
14
15SRCREV = "4ead3b8c189f217ee2c01ea3c56ef08d6a517f28"
16BRANCH ?= "ti-linux-firmware-4.1.y"
17
18SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
19
20S = "${WORKDIR}/git"
21
22TARGET = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf"
23
24do_install() {
25 install -d ${D}${base_libdir}/firmware/ti-pruss
26 for f in ${TARGET}; do
27 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
28 done
29}
30
31FILES_${PN} = "${base_libdir}/firmware"
32
33INSANE_SKIP_${PN} = "arch"