summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/prueth-fw
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2020-05-07 01:20:09 +0000
committerDenys Dmytriyenko <denys@ti.com>2020-05-07 01:14:16 +0000
commit29b8f2d7ce17b085237535a9fbcb02817d065a51 (patch)
tree323d3d34306a5114e1d61b41b3f9097bae8b691b /recipes-bsp/prueth-fw
parentd0996bea80d7467be120b8efdbf81379ced1c68d (diff)
downloadmeta-ti-29b8f2d7ce17b085237535a9fbcb02817d065a51.tar.gz
prueth-fw-am65x-sr2: add prebuilt PRU Ethernet FW for AM65x SR2.0
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/prueth-fw')
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
new file mode 100644
index 00000000..6e17c4aa
--- /dev/null
+++ b/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
@@ -0,0 +1,39 @@
1SUMMARY = "PRU Ethernet firmware for AM65xx SR2.0"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
5
6PV = "2.2.0.1+2.2.0.2-rc1"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx-evm"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14SRCREV = "ea4bf53ba0a4a30bb7e0e8b6138fdb22fe50372a"
15BRANCH ?= "ti-linux-firmware"
16
17SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
18
19S = "${WORKDIR}/git"
20
21TARGET = " \
22 am65x-sr2-pru0-prueth-fw.elf \
23 am65x-sr2-pru1-prueth-fw.elf \
24 am65x-sr2-rtu0-prueth-fw.elf \
25 am65x-sr2-rtu1-prueth-fw.elf \
26 am65x-sr2-txpru0-prueth-fw.elf \
27 am65x-sr2-txpru1-prueth-fw.elf \
28"
29
30do_install() {
31 install -d ${D}${base_libdir}/firmware/ti-pruss
32 for f in ${TARGET}; do
33 install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
34 done
35}
36
37FILES_${PN} = "${base_libdir}/firmware"
38
39INSANE_SKIP_${PN} = "arch"