diff options
author | Jacob Stiffler <j-stiffler@ti.com> | 2018-03-16 21:29:30 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-04-17 12:34:17 -0400 |
commit | 3be59ff6896e884e15fd83aa2cc13643d9cd4bf7 (patch) | |
tree | 6dad8b42799973c9b253fdf98c401a7045a8211d /recipes-bsp/prueth-fw/prueth-fw_git.bb | |
parent | fcf2647677143f05a2ecadac78fe69b57c5c5d3b (diff) | |
download | meta-ti-3be59ff6896e884e15fd83aa2cc13643d9cd4bf7.tar.gz |
prueth-fw: build firmware from source
* Use ti-cgt-pru to build the firmware images
Signed-off-by: Jacob Stiffler <j-stiffler@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
Diffstat (limited to 'recipes-bsp/prueth-fw/prueth-fw_git.bb')
-rw-r--r-- | recipes-bsp/prueth-fw/prueth-fw_git.bb | 46 |
1 files changed, 33 insertions, 13 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw_git.bb b/recipes-bsp/prueth-fw/prueth-fw_git.bb index 8359cf0b..5a671e3a 100644 --- a/recipes-bsp/prueth-fw/prueth-fw_git.bb +++ b/recipes-bsp/prueth-fw/prueth-fw_git.bb | |||
@@ -1,34 +1,54 @@ | |||
1 | DESCRIPTION = "PRU Ethernet firmware for AM57xx, AM437x, AM335x and K2G" | 1 | DESCRIPTION = "PRU Ethernet firmware for AM57xx, AM437x, AM335x and K2G" |
2 | 2 | ||
3 | LICENSE = "TI-TFL" | 3 | LICENSE = "TI-TFL" |
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | 4 | LIC_FILES_CHKSUM = "file://src/firmware_version.h;beginline=6;endline=53;md5=1f0a640a261059cdcbbcf01e6a739ff3" |
5 | 5 | ||
6 | require recipes-ti/includes/ti-paths.inc | ||
7 | |||
8 | ICSS_EMAC_LLD_GIT_URI = "git://git.ti.com/keystone-rtos/icss-emac.git" | ||
9 | ICSS_EMAC_LLD_GIT_PROTOCOL = "git" | ||
10 | ICSS_EMAC_LLD_GIT_BRANCH = "master" | ||
11 | ICSS_EMAC_LLD_GIT_DESTSUFFIX = "git/ti/drv/icss_emac" | ||
12 | |||
13 | # Below commit ID corresponds to "DEV.ICSS_EMAC_LLD.01.00.00.11B" | ||
14 | ICSS_EMAC_LLD_SRCREV = "bd643d75a0322b6ca769d8ecbee310d859c0f761" | ||
15 | |||
16 | BRANCH = "${ICSS_EMAC_LLD_GIT_BRANCH}" | ||
17 | SRC_URI = "${ICSS_EMAC_LLD_GIT_URI};destsuffix=${ICSS_EMAC_LLD_GIT_DESTSUFFIX};protocol=${ICSS_EMAC_LLD_GIT_PROTOCOL};branch=${BRANCH}" | ||
18 | |||
19 | SRCREV = "${ICSS_EMAC_LLD_SRCREV}" | ||
6 | PV = "5.1.4" | 20 | PV = "5.1.4" |
7 | PR = "r0" | 21 | PR = "r0" |
8 | 22 | ||
9 | CLEANBROKEN = "1" | 23 | S = "${WORKDIR}/${ICSS_EMAC_LLD_GIT_DESTSUFFIX}/firmware/icss_dualemac" |
10 | 24 | ||
11 | COMPATIBLE_MACHINE = "am57xx-evm|am437x-evm|am335x-evm|k2g" | 25 | COMPATIBLE_MACHINE = "am57xx-evm|am437x-evm|am335x-evm|k2g" |
12 | 26 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 27 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | 28 | ||
15 | SRCREV = "b9d9e4bef2f32d4b55a63ecfec2e21f7b1eaaa34" | 29 | DEPENDS = "ti-cgt-pru-native" |
16 | BRANCH ?= "ti-linux-firmware-4.1.y" | 30 | |
31 | PRU_VERSION = "" | ||
32 | PRU_VERSION_am335x-evm = "REV1" | ||
33 | PRU_VERSION_am437x-evm = "REV1" | ||
34 | PRU_VERSION_am57xx-evm = "REV2" | ||
35 | PRU_VERSION_k2g = "REV2" | ||
17 | 36 | ||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | 37 | FW_PREFIX = "" |
38 | FW_PREFIX_am335x-evm = "am335x" | ||
39 | FW_PREFIX_am437x-evm = "am437x" | ||
40 | FW_PREFIX_am57xx-evm = "am57xx" | ||
41 | FW_PREFIX_k2g = "k2g" | ||
19 | 42 | ||
20 | S = "${WORKDIR}/git" | ||
21 | 43 | ||
22 | TARGET_am57xx-evm = "am57xx-pru0-prueth-fw.elf am57xx-pru1-prueth-fw.elf" | 44 | EXTRA_OEMAKE += "CL_PRU_INSTALL_PATH="${TI_CGT_PRU_INSTALL_DIR}" PRU_VERSION_LIST="${PRU_VERSION}"" |
23 | TARGET_am437x-evm = "am437x-pru0-prueth-fw.elf am437x-pru1-prueth-fw.elf" | ||
24 | TARGET_am335x-evm = "am335x-pru0-prueth-fw.elf am335x-pru1-prueth-fw.elf" | ||
25 | TARGET_k2g = "k2g-pru0-prueth-fw.elf k2g-pru1-prueth-fw.elf" | ||
26 | 45 | ||
27 | do_install() { | 46 | do_install() { |
28 | install -d ${D}${base_libdir}/firmware/ti-pruss | 47 | install -d ${D}${base_libdir}/firmware/ti-pruss |
29 | for f in ${TARGET}; do | 48 | install -m 0644 ./elf/${PRU_VERSION}/icss_dualemac_PRU0.elf \ |
30 | install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f | 49 | ${D}${base_libdir}/firmware/ti-pruss/${FW_PREFIX}-pru0-prueth-fw.elf |
31 | done | 50 | install -m 0644 ./elf/${PRU_VERSION}/icss_dualemac_PRU1.elf \ |
51 | ${D}${base_libdir}/firmware/ti-pruss/${FW_PREFIX}-pru1-prueth-fw.elf | ||
32 | } | 52 | } |
33 | 53 | ||
34 | FILES_${PN} = "${base_libdir}/firmware" | 54 | FILES_${PN} = "${base_libdir}/firmware" |